Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
169 Views

DevCloud Access via PuTTY: Infinite Loop

Recently I was able to successfully connect to DevCloud using  64-bit PuTTY version 0.70 on Windows 10 version 1809 using these instructions: https://devcloud.intel.com/datacenter/learn/connect-with-ssh-windows.

Subsequently, when I try to connect, the plink program goes bererk by recursively creating instances of itself until the system runs out of memory.

I have done the following to no avail:

- Update PuTTY to version 0.73 (current version).
- Download the devcloud-access-key-xxxxx.ppk file again several times, and yes it is loaded into pageant before running PuTTY.
- Proxy is set to type=Local, Proxy hostname=proxy, Port=80, Telnet/proxy command="C:\Program Files\PuTTY\plink.exe" guest@devcloud.intel.com -nc %host:%port

- Session Hostname=uxxxx@c009, Port=22.
- Reconfirm intial connection sequence via the document:  OK.

Certainly this is a PuTTY rather than a DevCloud issue, but if anyone has a suggestion I'd appreciate it.

Tags (1)
0 Kudos
4 Replies
Highlighted
Employee
169 Views

Hi,

Thanks for reaching out to us.

We have tried it out from our end and it is working fine.
Please try to uninstall PuTTY and try installing it after downloading putty.exe from the following url.
( https://the.earth.li/~sgtatham/putty/latest/w64/putty.exe )

Also, make sure that you had downloaded the key from chrome/mozilla firefox as mentioned in devcloud.intel.com

Hope this helps.If you are still facing any issue please share the screenshot of the error that you are getting.We would be glad to help you.
 

0 Kudos
Highlighted
Beginner
169 Views

Still no luck.  Tried (1) the direct .exe-only download, (2) reinstalling using the .msi, and (3) downloading the key again (which I've always done with Chrome anyway)

I was just able to get this operational procedure to work on a differerent machine, and I can still connect on that machine after a reboot.

On this machine, though, I still get the same behavior.  When I open the connection, PuTTY invokes plink thousands of times (or plink is invoking itself).

There is no error to share via a screenshot.

Still hunting around on the Internet to see if anyone else has experienced this, but haven't found anything.

0 Kudos
Highlighted
Beginner
169 Views

SOLVED

If the Default Session settings accidently end up the the plink setting used for DevCloud you will see the behavior I described.  (From StackExchange https://superuser.com/questions/783857/excessive-plink-processes-using-putty-proxy).

In PuTTY:


1. Under Proxy, set Proxy type=None and Telnet command=connect %host %port\n

2. Under Sessions, select Default Session to make it the active selection, and click Save.
 

0 Kudos
Highlighted
Employee
169 Views

Hi,

It is glad to know that your issue got resolved. Thank you for your confirmation. We are closing this thread. Feel free to open new thread if you face further issues. 
 

0 Kudos