Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
1216 Discussions

Error accessing the arria10 node on Devcloud

Devdude
Novice
618 Views

I'm trying to use the arria10 FPGA to run some simulations. Upon logging in through interactive mode using the command:

qsub -I -l nodes=1:fpga_runtime:ppn=2 -d .

I get this error as soon as it finishes logging in:

/var/spool/torque/mom_priv/prologue.d//100-resetpcie.prologue: line 6: /sys/bus/pci/devices/0000:5e:00.0/remove: Permission denied

 

I get the same error when trying to login through the `devcloud_login` tool.

 

The script `100-resetpcie.prologue` tries to do the following:

#!/bin/bash

# Resetting FPGA Device
for x in `lspci | grep -i accel | grep -i intel | awk {'print $1'}`
do
echo 1 > /sys/bus/pci/devices/0000:$x/remove && sleep 1 && echo "1" > /sys/bus/pci/rescan
done

 

presumably to make sure the device(s) can be accessed. Trying to run this manually gives me the same error "Permission denied" to access the file.

 

When I try to run a synthesised bitstream (which had run before just a few days ago), it hangs forever when trying to get the device and it takes a while to kill the job.

 

Has anyone faced this issue before? I think a system reset is needed to properly release the board or so, but I'm not sure how to go about it.

0 Kudos
8 Replies
ChrisB_Intel
Moderator
603 Views

Our apologies for the issues. Are you working in OpenVino or Oneapi?


Thanks

Chris



ChrisB_Intel
Moderator
603 Views

Apologies for the issues you are running into. Are you working in OpenVino or OneAPI?


Thanks

Chris



Devdude
Novice
588 Views

Hi Chris, thanks for getting back to me. I'm currently working in oneAPI.

ChrisB_Intel
Moderator
586 Views

Thanks for clarifying, let me get the FPGA folks involved on this thread.


Thanks

Chris



GRN2
Employee
575 Views

You can try 

qsub -I -l nodes=1:arria10:ppn=2 -d .

BoonBengT_Intel
Moderator
556 Views

Hi @Devdude 

Thank you for posting in Intel community forum, hope all is well and apologies for the delayed in response.
Following up on the queries did you managed to try on the previous suggestion?

Please do let us know if the doubts are still here, and we would try our best to clarify.

 

Best Wishes
BB

BoonBengT_Intel
Moderator
551 Views

Hi @Devdude,

 

Good day, just checking in to see if there is any further doubts in regards to this matter.
Hope we have clarify your doubts.

Best Wishes
BB

BoonBengT_Intel
Moderator
526 Views

Hi @Devdude,

 

Greetings, unfortunately as we do not receive any further clarification on what is provided, we would assume challenge are resolved. Hence thread will no longer be monitored. For new queries, please feel free to open a new thread and we will be right with you. Pleasure having you here.

Best Wishes
BB

Reply