Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1695 Discussions

Error enumerating AFCs: no driver available

ChongzhouFang
Beginner
1,717 Views

Hi,

I am using OpenCL on an Aria 10 node and have generated an .aocx file. However, when I try to program the FPGA by using:

aocl program acl0 xxx.aocx

This error message pops out:

Error enumerating AFCs: no driver available
Error enumerating AFCs: no driver available
Error parsing device name '����'
aocl program: Running program from /opt/a10/inteldevstack/a10_gx_pac_ias_1_2_1_pv/opencl/opencl_bsp/linux64/libexec
Error parsing device name '����'
Error enumerating AFCs: no driver available
Error programming device
aocl program: Program failed.

 

I ran aocl diagnose command later and saw this error message in BSP Diagnostics:

BSP Diagnostics
--------------------------------------------------------------------
Error enumerating AFCs: no driver available
Error enumerating AFCs: no driver available
Error parsing device name '����'
Error enumerating AFCs: no driver available
Error parsing device name '����'

 

I am wondering what may be the cause of this, since previously everything works fine and I didn't change the .aocx file.

 

Thank you!

0 Kudos
8 Replies
AthiraM_Intel
Moderator
1,689 Views

Hi,


Thank you for posting in Intel Communities.


Could you please confirm whether you are using DevCloud for fpga?

Also share the node number in which you got this error and the screenshot for the same.



Thanks


0 Kudos
ChongzhouFang
Beginner
1,682 Views

Hi,

 

Thank you for the reply.

 

I am using node s005-n007. According to the devcloud_login options this should be a node supporting Arria 10 compiling and programming.

 

The screenshot is attached:

 

ChongzhouFang_1-1671221568918.png

 

0 Kudos
AthiraM_Intel
Moderator
1,185 Views

Hi,


Thank you for sharing the details and screenshot. We are working on this internally.




Thanks


0 Kudos
ChongzhouFang
Beginner
1,132 Views

Hi,

 

Thank you for taking care of this!

 

Just a quick follow-up on this issue:

Currently, are there any workarounds regarding this issue, if I still want to run my accelerators on Arria 10 FPGAs?

 

Thank you!

0 Kudos
AthiraM_Intel
Moderator
1,090 Views

Hi,


Our sincere apologies for the delay. We will update you once we find the resolution.



Thanks


0 Kudos
AthiraM_Intel
Moderator
1,002 Views

Hi,


Apologies for the delay.


The issue has been resolved. Could you please check from your side and let us know.




Thanks


0 Kudos
ChongzhouFang
Beginner
989 Views

Hi,

 

Thank you very much for your work! I confirm that it works.

 

Thanks.

0 Kudos
AthiraM_Intel
Moderator
981 Views

Hi,


Glad to know that your issue is resolved. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.



Thanks




0 Kudos
Reply