Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1596 Discussions

Failed to Connect to DevCloud via VS Code

rico22
New Contributor I
1,340 Views

Hi, everyone. I am trying to connect to the Intel DevCloud via VS Code. I followed all the instructions but I can't connect. It gives this message: 'Failed to automatically configure ssh config proxy settings'. What's happening? Can anyone help me out? Thank you for your time. 

0 Kudos
10 Replies
rico22
New Contributor I
1,339 Views

I am working on Windows.

0 Kudos
AlekhyaV_Intel
Moderator
1,315 Views

Hi,

 

Thank you for posting in Intel Communities.

 

Can you try the procedure below to make sure the Visual Studio Code is configured properly to connect to Intel DevCloud.

 

  • Open a Cygwin Terminal
  • Run the following command to rename and backup your original .ssh directory as .ssh_back
mv .ssh .ssh_back

 

  • Go to the Intel DevCloud website (https://devcloud.intel.com/oneapi/) and login to your Intel DevCloud account.
  • Then visit the link https://devcloud.intel.com/oneapi/documentation/connect-with-vscode/ to download the Intel DevCloud setup installer script as shown in the screenshot: "script_link.PNG".
  • Copy the installer script to the Cygwin installed home directory which is typically "C:\cygwin64\home\<username>\"
  • Once the above process is done, the installer script will be visible inside the Cygwin terminal
  • Execute the below command inside the Cygwin terminal to run the installer to set up the connection to Intel DevCloud
bash setup-devcloud-access-<devcloud_userID>.txt

 

  • Make sure you are not using any VPN or proxy and run the below command to evaluate the connection to Intel DevCloud by typing yes for the fingerprinting requests
ssh devcloud

 

  • Once the above process is successful, you can disconnect from Intel DevCloud and close the Cygwin terminal
  • Open Visual Studio Code and click Ctrl+Shift+P to open the command palette. Then choose "Intel DevCloud: Setup connection" from the list
  • Kindly wait for the connection to get established. This will try connecting to Intel DevCloud which will open a new Visual Studio Code window that is connected to Intel DevCloud via Visual Studio Code. This connection can be confirmed by checking the bottom status bar as shown in screenshot: "connection.PNG"

 

If this helps resolve your issue, do accept this as a solution as this will help others with a similar issue. If not, do get back to us.

 

Regards,

Alekhya

 

0 Kudos
rico22
New Contributor I
1,301 Views

Hi, Alekhya. These are the same instructions I followed previously. Unfortunately, the same result. I tried to connect to the Intel DevCloud via VS Code with a different laptop this time but still failed. I attached the picture. Can you please help me out? Thank you.

0 Kudos
rico22
New Contributor I
1,301 Views
0 Kudos
rico22
New Contributor I
1,246 Views

Hi, Alekhya. I think most of the users have problems connecting to Intel DevCloud via VS Code. There are issues with the key text or the setup script. Do you want to see my setup script? I can give it to you in a private message. Thank you.  

0 Kudos
jessica_nash
Beginner
1,257 Views

I am seeing this same message. I am on Windows 11 and tried both WSL and using cygwin (error message is the same in both). I am able to successfully `ssh devcloud` from both WSL and cygwin, but the VS Code extension says ":Failed to automatically configure ssh config proxy settings" when doing "Setup Connection".

AlekhyaV_Intel
Moderator
1,217 Views

Hi @rico22 ,


We need additional information to resolve your issue. Please answer our below questions:


1) Are you behind any proxy?

2) Yes, Please share your config file.


Regards,

Alekhya


Alexey_M
Employee
1,188 Views

@rico22 @jessica_nash 

Hello. There is a bug that prevents the ssh config file from being configured correctly in some cases. To understand if your problem is caused by this bug, I need to look at your config file, but the extension on the marketplace was also updated today and it contains a fix. You can try just to remove the extension and install it again(the correct extension version is 0.1.24). I hope this helps.

 

Best regards

rico22
New Contributor I
1,160 Views

Hi, Alekhya. I reinstall the extension and followed every step according to the instructions. It connects. Though I am working on the 'Windows' platform, I have to select the 'Linux' platform to work in the Intel DevCloud. Thank you.

0 Kudos
AlekhyaV_Intel
Moderator
1,157 Views

Hi,


Glad to know that your issue is resolved. Thank you for letting us know. If you need any further assistance, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Alekhya


0 Kudos
Reply