Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PBhar
Student Ambassador
1,311 Views

Installing jupyterlab extensions

I want to install extentions with jupyterlab. By default jupyter is installed in /glob/intel-python. Installing any extension gives this error:

(torch) u37216@s001-n148:~$ jupyter labextension install jupyterlab-flake8
An error occured.
OSError: [Errno 30] Read-only file system: '/glob/intel-python/versions/2018u2/intelpython3/share/jupyter/lab/extensions'
See the log file for details:  /home/u37216/tmp/jupyterlab-debug-uxbp6nz0.log

 

I want to install extensions from jupyterlab, it's okay If i'm able to change the installation path but I want it to be accessible via https://jupyter.devcloud.intel.com/user

Tags (1)
0 Kudos
13 Replies
ChithraJ_Intel
Moderator
1,311 Views

Hi Prajjwal,

Thanks for reaching out to us.
Could you please follow the below steps:

Step 1: Create a new conda environment  and activate the environment as

        conda create -n <env_name> python=3.6
        conda activate <env_name>  

     
Step 2: Install jupyterlab via conda

     conda install jupyterlab     

   
Step 3: If it's shows an error message to install nodejs, install it via conda
        

     conda install nodejs    


Step 4: Install the extensions with jupyterlab as follows

     jupyter labextension install jupyterlab-flake8     

      
[Note: Make sure that you are able to work in the correct conda environment you created]
Hope this resolve your issue.

PBhar
Student Ambassador
1,311 Views

As you can see, I executed the install command from my conda environment only.

(base) u37216@s001-n100:~$ conda activate torch
(torch) u37216@s001-n100:~$   conda install jupyterlab  

Collecting package metadata (current_repodata.json): done
Solving environment: done

# All requested packages already installed.

(torch) u37216@s001-n100:~$
(torch) u37216@s001-n100:~$
(torch) u37216@s001-n100:~$
(torch) u37216@s001-n100:~$  conda install nodejs   
Collecting package metadata (current_repodata.json): done
Solving environment: done

# All requested packages already installed.

(torch) u37216@s001-n100:~$  jupyter labextension install jupyterlab-flake8     An error occured.
OSError: [Errno 30] Read-only file system: '/glob/intel-python/versions/2018u2/intelpython3/share/jupyter/lab/extensions'
See the log file for details:  /home/u37216/tmp/jupyterlab-debug-0_1zmapq.log
(torch) u37216@s001-n100:~$

Not able to change environment even after conda activate is a problem in devcloud (https://software.intel.com/en-us/forums/intel-devcloud/topic/848741)

This does not leave much to the user if everything being used is system default. Docker support should be there.

AthiraM_Intel
Moderator
1,311 Views

Hi,

We understand your concern, the admin team is working to fix your path issue (https://software.intel.com/en-us/forums/intel-devcloud/topic/848741).Once it is resolved,you will be able to install the required extensions.

Thanks for your patience!!

ChithraJ_Intel
Moderator
1,311 Views

Hi Prajjwal,

We are forwarding this case to Devcloud admin team.

ChithraJ_Intel
Moderator
1,311 Views

Hi Prajjwal,

We have migrated from jupyter hub to jupyter lab. This would fix your issue. Cloud you please confirm the same.

 

PBhar
Student Ambassador
1,311 Views

The new jupyter hub keeps crashing now and then. It disconnects in the middle during training and is less stable. Don't know why these issue keeps arising with devcloud.

ChithraJ_Intel
Moderator
1,311 Views

Hi Prajjwal,

Could you please recheck if the issue exists. If it still persists, we will create a new account for you. And regarding the Jupyterlab consistency problem, the Devcloud admin team is checking on the issue.

Also, we have the following extensions installed on Jupyterlab as of Friday 3/20.

        @jupyter-widgets/jupyterlab-manager v2.0.0  enabled  OK
        @jupyterlab/github v2.0.0  enabled  OK
        @jupyterlab/toc v3.0.0  enabled  OK

If you are looking for any specific extensions,let us know the extension name.So,we can have it installed globally.

PBhar
Student Ambassador
1,311 Views

I tried two methods:

$ conda activate torch

$ jupyter labextension install jupyterlab-flake8

 

Returns An error occured.
OSError: [Errno 30] Read-only file system: '/glob/intel-python/versions/2018u2/intelpython3/share/jupyter/lab/extensions'
See the log file for details:  /home/u37216/tmp/jupyterlab-debug-ql37ka2m.log

 

I tried with extension manager from jupyter lab. When i enter the extension name, it returns

Error communicating with server extension. Consult the documentation for how to ensure that it is enabled.

Reason given:

Error: 500 (Internal Server Error)

Please see the screenshot for more details.

 

Also, the isolated conda environment problem is not solved.yet. All of my conda environments point toward the same environment. You'd already be aware of the problem through this forum. 

ChithraJ_Intel
Moderator
1,311 Views

Hi Prajjwal,

We have created a 120 days new account for you. This would fix your isolated conda environment problem( /glob/ issue). Regarding the extesnion that you are trying to install, the Devcloud admin team will look into JL-flake8 extension.

ChithraJ_Intel
Moderator
1,311 Views

Hi Prajjwal,

Could you please let us know more details about the use case which you are trying to achieve by getting JL-flake8 extension installed on Devcloud. Are you trying to do anything related to oneAPI using this?

ChithraJ_Intel
Moderator
1,311 Views

Hi Prajjwal,

Could you please confirm whether your are still facing the issue. If so, can you try to start a local jupyterlab instance from Devcloud and do a two way tunneling to open jupyterlab on your browser. For that, kindly follow the below steps:

Step 1: Create a new conda environment  and activate the environment as

conda create -n <env_name> python=3.6 
conda activate <env_name>

Step 2: Install jupyterlab via pip

pip install jupyterlab

Step 3: nodejs is required to install the jupyterlab extensions. Install it via conda:

conda install nodejs

[Note: Ignore the above steps if it done already.]

Step 4: In order to get this kernel in the jupyterlab instance that you are going to launch, install IPython kernel as follows:

conda install ipykernel
python -m ipykernel install --user --name <env_name>

Step 5: Launch a local jupyterlab instance from the current environment

jupyter lab --no-browser --port=8880

Step 6: For two way tunneling , open a new prompt and tunnel to login node of the Devcloud using the below command

ssh -L 8880:localhost:8880 devcloud_proxy

Then, tunnel to compute node as 

ssh -L 8880:localhost:8880 s001-n058

Where,

8880 :- Port in which jupyterlab is opened

s001-n058:- compute node in which your jupyterlab instance is running

Step 7: Open the jupyterlab on your browser with the URL obtained. Then, try to install the extension that you required using the extension manager.

Hopes this helps.

Thanks.

ChithraJ_Intel
Moderator
1,311 Views

Hi Prajjwal,

Please let us know whether your issue resolved or not. Are you able to install the required jupyterlab extension by starting a local jupyterlab instance and tunneling?

ChithraJ_Intel
Moderator
1,311 Views

Hi Prajjwal,

We are closing this case by assuming that your issue got resolved. Please feel free to raise a new thread if you have further issues.

Reply