Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jans
Beginner
414 Views

Logging into Intel® DevCloud for oneAPI (beta)

Hello

I am trying to connect to Intel@ DevCloud by steps given in https://devcloud.intel.com/oneapi/connect/

from Windows Putty. After completing all steps -> loading pkk into Pageant, opening session in Putty - all the time Protocol Mismatch error occurs (logging into gest account). The same is for logging into my DevCloud account. At the same time, logging from Ubuntu system, with loading keys works perfectly well.

All instructions were correctly fulfilled. Also converting keys given for OpenSSH to Putty format does not work.

How should be logging properly done in this situation?

 

Best regards,

JK

 

0 Kudos
9 Replies
RaeesaM_Intel
Moderator
388 Views

Hi ,

Thankyou for posting in Intel DevCloud Forum .


Please check these pre requisites while you connect to DevCloud via PuTTY :


1)     Check if you are behind a firewall or using a closed internet connection or proxy. If so, kindly try connecting once from an open internet connection to check if the issue has something to do with internet connection


2)     Make sure that you have downloaded the correct the keys – SSH keys for windows and the .ppk file is loaded to pageant every time you try to connect.


3)     In the configuration part : Make sure that the plink setting is properly given under “Telnet command or local proxy command” as given below: "C:\Program Files\PuTTY\plink.exe" guest@devcloud.intel.com -nc %host:%port . After updating the path, don't forget to go to "Session" and click 'Save'. Each time you want to open the connection, double click on your session name (say,  Intel DevCloud for oneAPI Projects) or select the name and click 'Load', followed by 'Open' button. Verify that the Host Name is changing from 'guest@devcloud.intel.com' to 'uXXXXX@c009' and the path in 'Proxy' section is appearing correctly once you clicked load.


For more details and suggestions regarding connectivity issues, refer

https://community.intel.com/t5/Intel-DevCloud/Getting-Starated-and-Frequently-asked-questions-on-Dev...


Please contact us if you still experience the same issue.


Thank you ,

Raeesa





Jans
Beginner
382 Views

Hello

 
No, it does not work.
 
With firewall turned off, no vpn, according to instructions the following screen appears:

 

oneapi.png 

 

 
At the same time there is no problem when connecting from Ubuntu 20.04.
 
Best regards
JK
RaeesaM_Intel
Moderator
373 Views

Hi,

We were able to follow the configuration steps without any connection error.

 

Please refer this link for detailed steps :

https://devcloud.intel.com/oneapi/connect/connect-with-ssh-windows/configuration

 

These are the areas in PuTTY where you have to make the changes :

·      In the side bar : Session

Change the Host name /ip address - uxxxxx@c009 ( where uxxxxx is your devcloud account id)

Connection type – SSH

Give session name

·      In the side bar : Connection : Proxy

Proxy type : Local

Telnet command or local proxy command : "C:\Program Files\PuTTY\plink.exe" guest@devcloud.intel.com -nc %host:%port

 

Now save your session .

Click on the name of your session from saved sessions

Load and open it.

 

Attaching herewith the screenshot of PuTTY configuration setup.

Also,Can you please share the screenshot of  your “Session” and “ connection : Proxy “ part in PuTTY .

 

Note : Please make sure that your access keys are still valid. DevCloud free access is for 28 days following which the access gets expired and try connecting to DevCloud Jupyter Hub using https://jupyter.devcloud.intel.com/ to check if your DevCloud access is still valid.

 

Hope this will work fine .

 

Thanks and Regards ,

Raeesa

 

Jans
Beginner
368 Views

 

now, the Session and Proxy section in Putty looks as in the instructions, but no connection is opened. Logging by JupiterHub works perfectly well.

 

JK

 

oneapi_logging.pngoneapi_session.pngoneapi_proxy.png

RaeesaM_Intel
Moderator
354 Views

Hi ,


Can you try by removing ‘plink’ in the Telnet command/local proxy command . Its expected to be : “C:\Program Files\PuTTY\plink.exe" guest@devcloud.intel.com -nc %host:%port

That might be the possible cause of connection error.


Raeesa


Jans
Beginner
342 Views

 

With Windows Putty maybe some configuration problem on my side.

Reasuming:

- JupyterHub connects to DevCloud without problems

- Ubuntu - after running installation script - connection is OK

- Windows, runs on OpenSSH,

(in user home directory,  file C:\Users\user_name\.ssh\config - should be copied from Linux - /home/pb/user_name/.ssh/config - if required some path should be adjusted for Windows)

Now, executing in command line - ssh devcloud - connects to DevCloud perfectly well.

Best regards

JK

 

 

 

 

RaeesaM_Intel
Moderator
329 Views

Hi ,


The problem might be because of PuTTY configuration. We were able to connect successfully using the above configuration and by following the steps specified in the link..

As you are able to connect to DevCloud using alternative methods, can we discontinue monitoring this query ?


Raeesa


Jans
Beginner
321 Views

Hello

 

Everything is OK. DevCloud connection works well in JupyterHub, Ubuntu and Windows by OpenSSH. 

The issue is resolved.

 

Best regards

JK

RaeesaM_Intel
Moderator
313 Views

Hi,


Thank you for the confirmation. We will no longer monitor this thread. Please raise a new thread if you have any further queries.


Raeesa


Reply