Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1683 Discussions

Permission Denied (public key)

robo_jz
Beginner
1,707 Views

I signed up for an account yesterday and was unable to get ssh access to the dev cloud. I used the automated script to set up the ssh keys. I checked the posts with similar issues and none of them were helpful.

0 Kudos
1 Solution
JananiC_Intel
Moderator
1,503 Views

Hi,

 

We apologize for the inconvenience caused by the public key error issue. Kindly follow the below steps.

 

Steps to check your account and remediate:

 

1.      Sign into DevCloud : https://devcloud.intel.com/oneapi/

2.      Login/launch Jupyter – Launch Jupyter

3.      Note down account number as shown below in the Welcome.ipynb notebook.

JananiC_Intel_0-1658990721331.png

 

4.      Next, login with ssh – if error does not show up your account is good.

5.      if permission denied(public key) error message shows up during login with ssh then:

a.      Check your .ssh/config : cat .ssh/config.

b.      Does your account number in your ssh/config match with the one showed in in Jupyter(Example : 12345).

c.      Make sure correct account number is reflected in the config file. If not, edit your .ssh/config to correct the account number in .ssh/config to be same as the one with what you see in Jupyter.

d.      Login with ssh again.

 

If at any point during the above steps you notice files missing please contact us with your original account number and the correct account number – we will work with the engineering team to help assist copy your files over.

 

Regards,

Janani Chandran

 

View solution in original post

0 Kudos
10 Replies
Serafina
Beginner
1,688 Views

I am in a very similar situation.

I launched with bash the script for the automatic ssh configuration, and I obtained the config file attached

(I renamed it to .txt only to be able  attach it ),

but trying to connect with ssh to the cloud, I got the following errors:

 

 (base) serafina@serafina-N501VW:~/.ssh$ ssh -v devcloud
OpenSSH_7.6p1 Ubuntu-4ubuntu0.6, OpenSSL 1.0.2n 7 Dec 2017
debug1: Reading configuration data /home/serafina/.ssh/config
debug1: /home/serafina/.ssh/config line 24: Applying options for devcloud
debug1: /home/serafina/.ssh/config line 72: Applying options for devcloud
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Executing proxy command: exec ssh -T -i ~/.ssh/devcloud-access-key-159897 guest@ssh.devcloud.intel.com
debug1: permanently_drop_suid: 1000
debug1: key_load_public: No such file or directory
debug1: identity file /home/serafina/.ssh/devcloud-access-key-159897 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/serafina/.ssh/devcloud-access-key-159897-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/serafina/.ssh/devcloud-access-key-159897 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/serafina/.ssh/devcloud-access-key-159897-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.6
Received disconnect from 12.229.61.118 port 22:2: Too many authentication failures
Disconnected from 12.229.61.118 port 22
ssh_exchange_identification: Connection closed by remote host

 

Can someone help me please?

I thank you in advance for any help you can provide me with.

0 Kudos
robo_jz
Beginner
1,684 Views

 

ssh -v devcloud
OpenSSH_8.1p1, LibreSSL 2.7.3
debug1: Reading configuration data /Users/jackzender/.ssh/config
debug1: /Users/jackzender/.ssh/config line 4: Applying options for devcloud
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 47: Applying options for *
debug1: Executing proxy command: exec ssh -T -i ~/.ssh/devcloud-access-key-xxxxx.txt guest@ssh.devcloud.intel.com
debug1: identity file /Users/jackzender/.ssh/devcloud-access-key-xxxxx.txt type -1
debug1: identity file /Users/jackzender/.ssh/devcloud-access-key-xxxxx.txt-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_8.1
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.6p1 Ubuntu-4ubuntu0.3
debug1: match: OpenSSH_7.6p1 Ubuntu-4ubuntu0.3 pat OpenSSH_7.0*,OpenSSH_7.1*,OpenSSH_7.2*,OpenSSH_7.3*,OpenSSH_7.4*,OpenSSH_7.5*,OpenSSH_7.6*,OpenSSH_7.7* compat 0x04000002
debug1: Authenticating to devcloud:22 as 'uxxxxx'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:7R/nUuhf2mWQej8YRr+FNr0T0++Rw71wmvZpsrysbFU
debug1: Host 'devcloud' is known and matches the ECDSA host key.
debug1: Found key in /Users/jackzender/.ssh/known_hosts:2
debug1: rekey out after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey in after 134217728 blocks
debug1: Will attempt key: /Users/jackzender/.ssh/devcloud-access-key-xxxxxx.txt  explicit
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /Users/jackzender/.ssh/devcloud-access-key-XXXXX.txt
debug1: Authentications that can continue: publickey
debug1: No more authentication methods to try.
uXXXXX@devcloud: Permission denied (publickey).

 

Hi serafina,

I ran with verbose flag and here is my output (instances of my user id are replaced with x's). I'm not sure if our problems are related but this may give some insight to a solution

 

 

0 Kudos
Serafina
Beginner
1,668 Views

I solved part of my problem, that was due to the fact that I have many ssh keys in the .ssh dir,

using the command:

ssh -v -XY -o IdentitiesOnly=yes -i /home/serafina/.ssh/devcloud-access-key-159897.txt guest@ssh.devcloud.intel.com

 

 

and now it seem that the authentication succeded, but everything stops at the last step below.

 

 

OpenSSH_7.6p1 Ubuntu-4ubuntu0.6, OpenSSL 1.0.2n 7 Dec 2017
debug1: Reading configuration data /home/serafina/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to ssh.devcloud.intel.com [12.229.61.118] port 22.
debug1: Connection established.
debug1: key_load_public: No such file or directory
debug1: identity file /home/serafina/.ssh/devcloud-access-key-159897.txt type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/serafina/.ssh/devcloud-access-key-159897.txt-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.6
debug1: Remote protocol version 2.0, remote software version OpenSSH_8.2p1 Ubuntu-4ubuntu0.5
debug1: match: OpenSSH_8.2p1 Ubuntu-4ubuntu0.5 pat OpenSSH* compat 0x04000000
debug1: Authenticating to ssh.devcloud.intel.com:22 as 'guest'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:fdh1CzIao2MCh6YQ3uP7ZZyZF0XqieU7OY6DjcDctq4
debug1: Host 'ssh.devcloud.intel.com' is known and matches the ECDSA host key.
debug1: Found key in /home/serafina/.ssh/known_hosts:1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,sk-ssh-ed25519@openssh.com,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,sk-ecdsa-sha2-nistp256@openssh.com>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/serafina/.ssh/devcloud-access-key-159897.txt
debug1: Authentication succeeded (publickey).
Authenticated to ssh.devcloud.intel.com ([12.229.61.118]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: pledge: network
debug1: client_input_global_request: rtype hostkeys-00@openssh.com want_reply 0
debug1: Remote: /opt/ssh/getkey %f:1: key options: agent-forwarding command permitopen port-forwarding pty user-rc x11-forwarding
debug1: Sending environment.
debug1: Sending env LANG = it_IT.UTF-8
SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.3

0 Kudos
JananiC_Intel
Moderator
1,652 Views

Hi,


Thanks for posting in Intel Forum.


We are working on this. We will get back to you soon.


Regards,

Janani Chandran


0 Kudos
DerekS
Beginner
1,620 Views

I am experiencing what seems to be exactly the same problem today when trying to create a new devcloud account and access via SSH. I've tried the process both with automated script and manual steps on both Windows and Linux with the result in all cases that the pubkey authentication is rejected. Hoping there will be an update soon, 

0 Kudos
Cool_Br33ze
Beginner
1,581 Views

Same here for the past week, no luck ssh-ing into devcloud after automatic/manual installation (opened a completely new user as well), same problem and same verbose output exactly as Serafina posted.

Any news on this issue? any estimation when will this problem be solved?

0 Kudos
JananiC_Intel
Moderator
1,550 Views

Hi,


Regarding permission denied issue, the error was due to a bug on the web portal SSO introduced Thursday July 14th at ~1pm and resolved at ~10am July 15th. In fixing this bug, if you are still getting this error, please down load the public key as shown in the credentials email.


If you are still facing this issue then let us know.


Regards,

Janani Chandran


0 Kudos
Cool_Br33ze
Beginner
1,541 Views

@JananiC_Intel Re-downloaded the public key, new installation (Automated and Manually), via this link instructions:

https://devcloud.intel.com/oneapi/documentation/connect-with-ssh-linux-macos/

 

The problem still exist and remains - with no ability to SSH into devcloud.

 

Please help!

 

0 Kudos
JananiC_Intel
Moderator
1,504 Views

Hi,

 

We apologize for the inconvenience caused by the public key error issue. Kindly follow the below steps.

 

Steps to check your account and remediate:

 

1.      Sign into DevCloud : https://devcloud.intel.com/oneapi/

2.      Login/launch Jupyter – Launch Jupyter

3.      Note down account number as shown below in the Welcome.ipynb notebook.

JananiC_Intel_0-1658990721331.png

 

4.      Next, login with ssh – if error does not show up your account is good.

5.      if permission denied(public key) error message shows up during login with ssh then:

a.      Check your .ssh/config : cat .ssh/config.

b.      Does your account number in your ssh/config match with the one showed in in Jupyter(Example : 12345).

c.      Make sure correct account number is reflected in the config file. If not, edit your .ssh/config to correct the account number in .ssh/config to be same as the one with what you see in Jupyter.

d.      Login with ssh again.

 

If at any point during the above steps you notice files missing please contact us with your original account number and the correct account number – we will work with the engineering team to help assist copy your files over.

 

Regards,

Janani Chandran

 

0 Kudos
JananiC_Intel
Moderator
1,448 Views

Hi,


Thanks for accepting our solution. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Janani Chandran


0 Kudos
Reply