Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1590 Discussions

Permission denied (publickey)

PBhar
Student Ambassador
4,515 Views

I'm unable to ssh into my account.

❯ ssh devcloud

u37216@devcloud:  Permission denied (publickey)

I'm getting the above error.

 

0 Kudos
20 Replies
AthiraM_Intel
Moderator
4,515 Views

Hi,

Thanks for reaching out to us.

Could you please verify the given config file with yours  

Host devcloud
User uxxxxx
HostName c009
Port 4036
IdentityFile "<Path>/devcloud-access-key-xxxxx.txt"
ProxyCommand ssh -T -i "<Path>/devcloud-access-key-xxxxx.txt" guest@devcloud.intel.com

If there is no change , please download the key once more and try again.

Manually verify whether the key file is present in the ~/.ssh folder and set correct permissions as below:

chmod 600 ~/.ssh/devcloud-access-key-xxxxx.txt
chmod 600 ~/.ssh/config 

If the issue still persists, please let us know.

0 Kudos
PBhar
Student Ambassador
4,516 Views

Yes. I've verified. I followed the same instructions which I received in the welcome email. The issue still persists.

0 Kudos
Dan_P_Intel
Employee
4,516 Views

Hey Prajjwal,

Perhaps there's an easier way to reconfigure your SSH connection.

Step1: backup your ~/.ssh folder. For example you can rename it to: ~/.ssh.old.

Step2: go to https://devcloud.intel.com/oneapi/connect/connect-with-ssh-linux-macos/.
Not long ago we have added a script to automate the SSH config for the DevCloud. Follow the instructions and let us know if that solved your connection problem.

Thank you!
 

0 Kudos
PBhar
Student Ambassador
4,516 Views

I followed this same instructions as you said. It still doesn't work.

0 Kudos
AthiraM_Intel
Moderator
4,516 Views

Hi Prajjwal,

We have sent you new credentials, please download the keys as described under the "connect" section. Please find the attached screenshot of the connect section.

If you face any issue please let us know.

 

Thanks

0 Kudos
PBhar
Student Ambassador
4,516 Views

I tried with both automated and manual. It still doesn't work.

0 Kudos
AthiraM_Intel
Moderator
4,516 Views

Hi Prajjwal,

We couldn't observe any issue in DevCloud connection from our end

Could you please share the complete steps you followed so that we can verify.

 

Thanks

0 Kudos
PBhar
Student Ambassador
4,516 Views

Automated:

bash ~/Downloads/setup-devcloud-access-37216.txt

 

Manual

mv ~/Downloads/devcloud-access-key-37216.txt ~/.ssh/

 

This step: Add the following lines to file ~/.ssh/config (if you do not have this file, simply create one)

chmod 600 ~/.ssh/devcloud-access-key-37216.txt chmod 600 ~/.ssh/config

0 Kudos
AthiraM_Intel
Moderator
4,493 Views

Hi Prajjwal,


We have contacted the concerned team. Will get back to you soon.


Thanks



0 Kudos
AthiraM_Intel
Moderator
4,424 Views

Hi Prajjwal,


We have already sent the new credentials to you. If you are still facing the same issue, then your account is corrupted beyond recovery. You can apply for a new account here https://intelsoftwaresites.secure.force.com/DevCloud/


Could you please let us know if we can close this case?


Thanks


0 Kudos
AthiraM_Intel
Moderator
4,385 Views

Hi,


We haven't heard back anything from you. So, we are closing this case assuming that your issue is resolved . Please feel free to raise a new thread if you have any further issues.


Thanks.


0 Kudos
OmJadhav
Beginner
3,507 Views

I am getting the same error, can anyone please help me to get resolve this error,

 

OM@DESKTOP-ROHK79L ~
$ ssh devcloud
u79954@devcloud: Permission denied (publickey).

 

 

 

 

0 Kudos
ral
Novice
3,456 Views

Also am getting the same issue 

0 Kudos
fcharras
Beginner
3,317 Views

Same issue to report here.

0 Kudos
I_I
Beginner
3,230 Views

Same issue here for me, user id is "u155562", ssh response is "receive packet: type 51"

 

debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug3: send packet: type 50
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey
debug3: start over, passed a different list publickey
debug3: preferred hostbased,publickey,password,keyboard-interactive
debug3: authmethod_lookup publickey
debug3: remaining preferred: password,keyboard-interactive
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/mobaxterm/.ssh/devcloud-access-key-155562.txt
debug3: sign_and_send_pubkey: RSA SHA256:iB1fNwgTBJeBE1wkhN5SR81WhiCZ1LgHj4yQ1l5Ep5s
debug3: send packet: type 50
debug2: we sent a publickey packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
Permission denied (publickey).

0 Kudos
myp
Beginner
3,180 Views

same issue for me 

u162758@devcloud: Permission denied (publickey).

0 Kudos
ProjectPhysX
Beginner
2,813 Views

Any updates on this? I did the automated setup script and face the same issue.

0 Kudos
YashOswalYO
Beginner
2,622 Views

I am also facing the same issue? any fix?

0 Kudos
Andrzej2
Employee
2,515 Views

the same for u178060,  Permission denied (publickey).

0 Kudos
Aaron_M
Beginner
2,156 Views

Yeah, Also here...

u168601@devcloud: Permission denied (publickey).

Initially it was working fine not until my cloud access expired. I asked for extension and the credentials on cloud changed to u184096 instead of the initial u168601.

I guess when running ssh devcloud in terminal, it gets over to the former u168601 connection instead of the current u184096 connection.

0 Kudos
Reply