Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
674 Discussions

Problem of connecting to DevCloud from VSCode through Cygwin on Windows 10

howard_l
Novice
932 Views
First timer to use DevCloud. I have installed Cygwin on my Windows 10.  After following the Instruction https://devcloud.intel.com/oneapi/documentation/connect-with-vscode/ , I have got the following error in my VSCode.  However, I can connect successfully in my Cygwin terminal which means I do have my proper devcloud-access-key file.  
 
[16:42:54.887] Using SSH config file "C:\cygwin64\home\user\.ssh\config"
[16:42:54.888] Running script with connection command: "C:\cygwin64\bin\ssh.exe" -T -D 4768 -F "C:\cygwin64\home\user\.ssh\config" devcloud bash
[16:42:54.892] Terminal shell path: C:\WINDOWS\System32\cmd.exe
[16:42:55.216] > Warning: Identity file /home/user/.ssh/devcloud-access-key-xxxxx.txt not accessib
> le: No such file or directory.
> ]0;C:\WINDOWS\System32\cmd.exe
[16:42:55.217] Got some output, clearing connection timeout
[16:42:55.898] > guest@devcloud.intel.com: Permission denied (publickey,gssapi-keyex,gssapi-with-
> mic).
 
Any help will be appreciated. 
 
 
0 Kudos
1 Solution
ArunJ_Intel
Moderator
892 Views

Hi Howard,


This issue might be due to some permission issues for ssh to access files from the cygwins directory. Below are 2 alternatives both of which should work.



Option 1

Change permissions of your key file. Right-click on key then select "Properties". Navigate to the "Security" tab and click "Advanced".

Change the owner to you, disable inheritance and delete all permissions. Then grant yourself "Full control" and save the permissions. Now SSH won't complain about file permission too open anymore.


Option 2

move the key to any common path. For eg downloads(C:\Users\username\Downloads\). And try ssh again.


Let us know if this still doesn't work.





Thanks

Arun


View solution in original post

6 Replies
ArunJ_Intel
Moderator
909 Views

Hi Howard,

 

Could you please change the path to your key in the config file. You should provide windows path(eg C:\cygwin64\home\user\.ssh\key.txt) instead of Linux path (/home/user/.ssh/key.txt) which may not be valid outside Cygwin shell.

 

 

Below is an example for config file entry.

 

Host devcloud
User uXXXX
HostName c009
Port 4036
IdentityFile C:\cygwin64\home\user\.ssh\devcloud-access-key-XXXX
ProxyCommand C:\cygwin64\bin\ssh.exe -T -i C:\cygwin64\home\user\.ssh\devcloud-access-key-XXXX guest@devcloud.intel.com



Let me know if you are still facing any issues with connection.

 

Thanks

Arun

 

howard_l
Novice
902 Views

I did gave a try of changing the linux path to windows path before, but I got a different error complaining about the permission of my identityfile:

Permissions for 'c:/cygwin64/home/user/.ssh/devcloud-access-key-xxxxx.txt' are to
> o open.
> It is required that your private key files are NOT accessible by others.        
> This private key will be ignored.
> Load key "c:/cygwin64/home/user/.ssh/devcloud-access-key-xxxxx.txt": bad permissi
> ons
ArunJ_Intel
Moderator
893 Views

Hi Howard,


This issue might be due to some permission issues for ssh to access files from the cygwins directory. Below are 2 alternatives both of which should work.



Option 1

Change permissions of your key file. Right-click on key then select "Properties". Navigate to the "Security" tab and click "Advanced".

Change the owner to you, disable inheritance and delete all permissions. Then grant yourself "Full control" and save the permissions. Now SSH won't complain about file permission too open anymore.


Option 2

move the key to any common path. For eg downloads(C:\Users\username\Downloads\). And try ssh again.


Let us know if this still doesn't work.





Thanks

Arun


View solution in original post

howard_l
Novice
884 Views

Hi Arun,

It seems my account is disabled. Even doing "ssh devcloud" from my cygwin window get me this following error:

kex_exchange_identification: read: Connection reset by peer
Connection reset by 12.229.61.118 port 22
kex_exchange_identification: Connection closed by remote host
Connection closed by UNKNOWN port 65535

This is same error I got when using Option 1 from your suggestion. my account is u57442.

thanks

Howard

 

 

howard_l
Novice
881 Views

Hi Arun,

please ignore my previous reply. I can successfully login in to my account now using Option 1 after my account was reenabled. 

many thanks

Howard 

ArunJ_Intel
Moderator
872 Views

Thanks Howard for the confirmation. We wouldn't be monitoring replies to this thread further please raise a new case in case of further issues.


Reply