Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
1216 Discussions

Quartus not install on fpga_compile nodes

murrtank
Novice
640 Views

I am trying to compile my code to fpga on the fpga_compile nodes, but I am getting this error:

aoc: This compilation stage requires an installation of Intel(R) Quartus(R) Prime software!
aoc: However Quartus was not found on the PATH or passed in using QUARTUS_ROOTDIR_OVERRIDE.
aoc: If you have a valid installation, please pass it in using QUARTUS_ROOTDIR_OVERRIDE or add it to the PATH.
aoc: Otherwise, consider downloading Quartus from here: https://www.intel.com/content/www/us/en/software-kit/661712/intel-quartus-prime-pro-edition-design-software-version-19-2-for-linux.html

 Why is this? Something I need to do or an error on the nodes?

9 Replies
Mdcc_UVa
New Contributor I
602 Views

It seems that now you have to execute some bash scripts to setup the oneAPI variables so that Quartus is seen on the path. See: https://devcloud.intel.com/oneapi/documentation/job-submission/

 

Specifically:

# For Arria 10
source /glob/development-tools/versions/fpgasupportstack/a10/1.2.1/inteldevstack/init_env.sh
# For Stratix 10
source /glob/development-tools/versions/fpgasupportstack/d5005/2.0.1/inteldevstack/init_env.sh


Now, I know for sure this hasn't always been the case, but now whenever I try to compile an FPGA kernel without sourcing the specified files, I get an error similar to yours.

murrtank
Novice
582 Views

Now I get this error instead? Any idea on what it could be?

Board '/opt/intel/oneapi/intel_a10gx_pac:pac_a10' not found.
Searched in the board package at: 
  /glob/development-tools/versions/fpgasupportstack/a10/1.2.1/inteldevstack/a10_gx_pac_ias_1_2_1_pv/opencl/opencl_bsp
Board list:
  pac_a10
     Board Package: /glob/development-tools/versions/fpgasupportstack/a10/1.2.1/inteldevstack/a10_gx_pac_ias_1_2_1_pv/opencl/opencl_bsp

If you are using a 3rd party board, please ensure:
  1) The board package is installed (contact your 3rd party vendor)
  2) You have used -board-package=<bsp-path> to specify the path to
     your board package installation
Error: No board_spec.xml found for board '/opt/intel/oneapi/intel_a10gx_pac:pac_a10' (Searched for: /glob/development-tools/versions/fpgasupportstack/a10/1.2.1/inteldevstack/a10_gx_pac_ias_1_2_1_pv/opencl/opencl_bsp/hardware//opt/intel/oneapi/intel_a10gx_pac:pac_a10/board_spec.xml).
llvm-foreach: 

 

filipeborralho
579 Views

I had the same error before and when I added those extra lines to my script:

#!/bin/bash
source /opt/intel/inteloneapi/setvars.sh

#Initialize environment for Arria10
source /glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/init_opencl.sh
source /glob/development-tools/versions/fpgasupportstack/a10/1.2.1/inteldevstack/init_env.sh

export FPGA_BBB_CCI_src=/usr/local/intel-fpga-bbb
export PATH=/glob/intel-python/python2/bin:${PATH}

#FPGA Bitstream Compilation for Arria10
dpcpp -fintelfpga -Xshardware -Xsboard=/opt/intel/oneapi/intel_a10gx_pac:pac_a10 -Xsread-only-cache-size=2048 *.cpp

I got the same error you described so I changed the script to:

#!/bin/bash
source /opt/intel/inteloneapi/setvars.sh

#Initialize environment for Arria10
source /glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/init_opencl.sh
source /glob/development-tools/versions/fpgasupportstack/a10/1.2.1/inteldevstack/init_env.sh

export FPGA_BBB_CCI_src=/usr/local/intel-fpga-bbb
export PATH=/glob/intel-python/python2/bin:${PATH}

#FPGA Bitstream Compilation for Arria10
dpcpp -fintelfpga -Xshardware -Xsread-only-cache-size=2048 *.cpp

 And now I get the following:

InvalidBuiltinSetName: Expects OpenCL.std. Actual is OpenCL.DebugInfo.100 [Src: /build/psgswbuild/nightly/19.4/64/l64/p4/acl/llvm/projects/llvm-spirv/lib/SPIRV/libSPIRV/SPIRVModule.cpp:712 SPIRVBuiltinSetNameMap::rfind(BuiltinSetName, &BuiltinSet) ]
Stack dump:
0.	Program arguments: /glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/linux64/bin/../../llvm/bin/aocl-llvm-spirv -r /tmp/ttm-8fd002-a8db3c.spv -o /tmp/ttm-66f253-64d8c9.2836384.temp/spirv.fpga.bc 
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/llvm/bin/../lib/libLLVM-9svn.so(_ZN4llvm3sys15PrintStackTraceERNS_11raw_ostreamE+0x2a)[0x7f1aee31320a]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/llvm/bin/../lib/libLLVM-9svn.so(_ZN4llvm3sys17RunSignalHandlersEv+0x4c)[0x7f1aee31087c]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/llvm/bin/../lib/libLLVM-9svn.so(+0xe209cc)[0x7f1aee3109cc]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x14420)[0x7f1aed4d1420]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0xcb)[0x7f1aece2000b]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x12b)[0x7f1aecdff859]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/llvm/bin/../lib/libLLVM-9svn.so(+0x3bf5034)[0x7f1af10e5034]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/llvm/bin/../lib/libLLVM-9svn.so(_ZN5SPIRV15SPIRVModuleImpl22importBuiltinSetWithIdERKSsj+0x1b6)[0x7f1af11b04f6]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/llvm/bin/../lib/libLLVM-9svn.so(_ZN5SPIRV18SPIRVExtInstImport6decodeERSi+0x8d)[0x7f1af115f7bd]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/llvm/bin/../lib/libLLVM-9svn.so(_ZN5SPIRVrsERSiRNS_10SPIRVEntryE+0x13)[0x7f1af115c743]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/llvm/bin/../lib/libLLVM-9svn.so(_ZN5SPIRV12SPIRVDecoder8getEntryEv+0xc6)[0x7f1af11b48a6]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/llvm/bin/../lib/libLLVM-9svn.so(_ZN5SPIRVrsERSiRNS_11SPIRVModuleE+0x30e)[0x7f1af11b0c0e]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/llvm/bin/../lib/libLLVM-9svn.so(_ZN5SPIRV15readSpirvModuleERSiRSs+0x26)[0x7f1af10d8286]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/llvm/bin/../lib/libLLVM-9svn.so(_ZN4llvm9readSpirvERNS_11LLVMContextERSiRPNS_6ModuleERSs+0x2e)[0x7f1af10fb48e]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/linux64/bin/../../llvm/bin/aocl-llvm-spirv(+0x5666)[0x559bc3322666]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/linux64/bin/../../llvm/bin/aocl-llvm-spirv(+0x39e8)[0x559bc33209e8]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3)[0x7f1aece01083]
/glob/development-tools/versions/fpgasupportstack/a10/1.2.1/intelFPGA_pro/hld/linux64/bin/../../llvm/bin/aocl-llvm-spirv(+0x3d01)[0x559bc3320d01]
Error: SPIRV to LLVM IR FAILED
llvm-foreach: 
dpcpp: error: fpga compiler command failed with exit code 1 (use -v to see invocation)

 Since I'm also struggling with compiling anything, I hope I've provided helpful information to find the source of the problem.

Mdcc_UVa
New Contributor I
573 Views

Those problems seem to be related to the BSP used to compile the kernels (i.e. "/opt/intel/oneapi/intel_a10gx_pac"), which, as far as I know, it is required to specify one when compiling an FPGA kernel.
Now, I don't think I am the most indicated person to tell you which one to use, since I am also experiecing problems with FPGA compilation. Besides, I use OpenCL instead of DPC++, so your scripts are slightly different to mines, which I understand better.

Just in case you have any luck with that, I am trying the BSPs which can be found in the "/glob/development-tools/versions/oneapi/" tree of subfolders. For example: /glob/development-tools/versions/oneapi/2022.3.1/oneapi/intel_a10gx_pac

AlekhyaV_Intel
Moderator
572 Views

Hi,


We apologize for the inconvenience caused. We are working on this internally, we will get back to you soon with an update.


Regards,

Alekhya


JVand22
Beginner
477 Views

I've been having the same issue. Are there any updates yet? Or known workarounds? Thanks!

AlekhyaV_Intel
Moderator
390 Views

Hi All,

 

Please try the following workaround:

 

$ QUARTUS_ROOTDIR_OVERRIDE=/opt/intel/intelFPGA_pro/19.2/quartus <make_or_cmake_command>

 

The idea is to set the environment variable manually.

 

For future reference, the QUARTUS_ROOTDIR_OVERRIDE env var should not be empty and should point to the latest installation of Quartus.

 

$ echo $QUARTUS_ROOTDIR_OVERRIDE
/opt/intel/intelFPGA_pro/19.2/quartus

 

If this resolves your issue, make sure to accept this as a solution. This helps others with similar issue.

 

Regards,

Alekhya

 

 

 

murrtank
Novice
319 Views

I'm a littel unsure how you want me to use the command? Is the first for the makefile and second for bash file? It didn't work form me atleast.  But now i notice that it's not a quartus problem anymor but a board problem?

Error: No board_spec.xml found for board '/opt/intel/oneapi/intel_a10gx_pac:pac_a10' (Searched for: /glob/development-tools/versions/fpgasupportstack/a10/1.2.1/inteldevstack/a10_gx_pac_ias_1_2_1_pv/opencl/opencl_bsp/hardware//opt/intel/oneapi/intel_a10gx_pac:pac_a10/board_spec.xml).
llvm-foreach:

 This is the error i get now?  

AlekhyaV_Intel
Moderator
287 Views

Hi @murrtank ,


As you've raised a new thread(Can't find board.xml file) on the board issue and we have provided the solution for initial issue, closing this thread. If you need any further assistance, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Alekhya


Reply