Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1719 Discussions

Quartus tcl error on fpga compile

Ruchit_rt
New Contributor I
5,494 Views

I have the following hardware.sh script:

 

#!/bin/bash
source /opt/intel/oneapi/setvars.sh > /dev/null 2>&1
export PKG_CONFIG_PATH=/home/u196631/opencv_install/lib/pkgconfig:$PKG_CONFIG_PATH
export QUARTUS_ROOTDIR=/glob/development-tools/versions/intelFPGA_pro/19.2/quartus/
export QSYS_ROOTDIR=/glob/development-tools/versions/intelFPGA_pro/19.2/qsys/bin
export PATH="$QUARTUS_ROOTDIR/bin:$QSYS_ROOTDIR:$PATH"
cd /home/u196631/urop/final-year-project/
icpx -v -fsycl -fintelfpga -DFPGA_HARDWARE src/model_quantised.cpp -Xshardware -o model_quantised.fpga -Xstarget=intel_s10sx_pac:pac_s10_usm $(pkg-config --cflags --libs opencv4)
 
which I submit as follows on intel dev cloud: 
qsub -l nodes=1:fpga_compile:ppn=2 scripts/hardware.sh -l walltime=23:00:00
 
I get the following error related to tcl:
output logoutput logerr logerr log
 
In text the err:
Info: Command: quartus_sh -t build/entry.tcl import
Info: Quartus(args): import
Error (23018): Tcl Script File build/entry.tcl not found
Error (23031): Evaluation of Tcl script build/entry.tcl unsuccessful
 
I am not able to compile on fpga. Can someone please guide me?
 
Thank you!
Labels (1)
0 Kudos
22 Replies
JaideepK_Intel
Employee
4,261 Views

Hi,

 

Thank you for posting in Intel Communities.

 

We ran a vector-add sample from our end without any issues.

link: https://github.com/oneapi-src/oneAPI-samples/tree/master/DirectProgramming/C%2B%2BSYCL/DenseLinearAlgebra/vector-add#base-vector-add-sample

 

Could you please share the sample reproducer? (sample reproducer is an exact replica of your working sample)

 

Could you please try to run your script with the below command?

 

qsub -l nodes=1:stratix10:ppn=2 -d <path to the sample> <sample_name>

example:
qsub -l nodes=1:stratix10:ppn=2 -d . ./build.sh

Thanks,

Jaideep

 

 

 

0 Kudos
Ruchit_rt
New Contributor I
4,248 Views

The example follows the cmakelists process by building a build directory and all. Is it not possible to do it the way I have done by submitting the hardware script?

 

I did not understand what you meant by sample reproducer.

 

I have run the job as you stated above and am waiting to get back logs from it. It seems to be runnning at the moment.

 

Let me know about above queries.

 

Thank you!

0 Kudos
JaideepK_Intel
Employee
4,223 Views

Hi,

 

I can see you are using a script named model_quantized.cpp. Does it come with one API sample? If yes, share the exact path or share a sample reproducer to reproduce your issue. It's good to know you are able to run your script with the above command, if you still face the issue share log files too.

 

Thanks,

Jaideep

 

0 Kudos
Ruchit_rt
New Contributor I
4,218 Views

Its not from a sample. Its a file that was written by me and others for a project. Would you want the directory structure or the file?

0 Kudos
Ruchit_rt
New Contributor I
4,201 Views

Jaideep,

I got this in the error logs, i had set the walltime to 23 hours before. 

 

=>> PBS: job killed: cput 270126 exceeded limit 270000
/opt/intel/inteloneapi/setvars.sh: line 708: export: `QUARTUS_PRIME_19.2=/glob/development-tools/versions/oneapi/2022.3.1/intelFPGA_pro/19.2/quartus': not a valid identifier
/opt/intel/inteloneapi/setvars.sh: line 710: export: `QUARTUS_PRIME_21.2=/glob/development-tools/versions/intelFPGA_pro/21.2/quartus': not a valid identifier
/opt/intel/inteloneapi/setvars.sh: line 711: export: `QUARTUS_PRIME_22.4=/glob/development-tools/versions/intelFPGA_pro/22.4/quartus': not a valid identifier
/opt/intel/inteloneapi/setvars.sh: line 713: export: `QUARTUS_PRIME_23.1=/glob/development-tools/versions/intelFPGA_pro/23.1/quartus': not a valid identifier
/usr/sbin/kill-illegit-procs: line 109: /dev/shm/kip-jobs-1690274471.tmp: No such file or directory

 

Not sure what's going wrong here.

0 Kudos
Ruchit_rt
New Contributor I
4,199 Views

Can you confirm if the error is due to the walltime or are there some other issues with the code?

0 Kudos
JaideepK_Intel
Employee
4,144 Views


Hi,

 

Yes, please share the samples/replica of the sample to reproduce the issue from our end.

 

>>PBS: job killed: cput 270126 exceeded limit 270000

Yes, you got this error because your sample is running longer than the wall time that you mentioned.


We can see you raised a new case on the same issue, can we go ahead and mark that case as duplicate so we can assist you here?


Thanks,

Jaideep



0 Kudos
Ruchit_rt
New Contributor I
4,134 Views

How can I share the entire project? Should I sent a GitHub link?

0 Kudos
Ruchit_rt
New Contributor I
4,095 Views

Dear Jaideep,

Please find a link to the GitHub repo that I am using: https://github.com/Ruchit-rt/fgpa_hardware_accelerateNN

 

As described in the first post in this thread is the process used for hardware compile. There is an issue with quartus in this as you can see after a lengthy run of the job. Please let me know how I should proceed.

0 Kudos
JaideepK_Intel
Employee
4,088 Views

Hi,


Thanks for sharing the repo, we will work on this and get back to you with an update.


Thanks,

Jaideep


0 Kudos
JaideepK_Intel
Employee
4,015 Views

Hi,

 

We can see the script you provided above has been running for more than 24 hours. attaching screenshots for reference. We created a job.sh script and pasted the commands that you provided above.

 

job.sh:

 

#!/bin/bash
source /opt/intel/oneapi/setvars.sh > /dev/null 2>&1
#export PKG_CONFIG_PATH=/home/u196631/opencv_install/lib/pkgconfig:$PKG_CONFIG_PATH
export QUARTUS_ROOTDIR=/glob/development-tools/versions/intelFPGA_pro/19.2/quartus/
export QSYS_ROOTDIR=/glob/development-tools/versions/intelFPGA_pro/19.2/qsys/bin
export PATH="$QUARTUS_ROOTDIR/bin:$QSYS_ROOTDIR:$PATH"
cd /home/u113485/jai/quar/fgpa_hardware_accelerateNN/
icpx -v -fsycl -fintelfpga -DFPGA_HARDWARE src/model_quantised.cpp -Xshardware -o model_quantised.fpga -Xstarget=intel_s10sx_pac:pac_s10_usm $(pkg-config --cflags --libs opencv4)

 


output log:

JaideepK_Intel_0-1690953564609.png

error log:

JaideepK_Intel_1-1690953603483.pngJaideepK_Intel_2-1690953627914.png

 

In DevCloud, the maximum wall time for all the nodes was 24 hours. If you have any other doubts, please let us know or If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue.

 

Thanks,

Jaideep

 

 

 

 

0 Kudos
Ruchit_rt
New Contributor I
3,976 Views

Jaideep, 

You can see the openCV not found error that you recieved. i have provided openCV package along with the repo so you can use that by setting the library path. Once you do that, the quartus error will show up. 

 

The time limit exceeded issue is different - the quartus error will also present itself within 5 minutes if you execute the scipt in interactive mode on a FPGA node like startix.

 

Please let me know how we can setup quartus environment variables and use the correct version correctly. The issue lies somewhere with the quartus version incompatibility.

0 Kudos
JaideepK_Intel
Employee
3,969 Views

Hi,

 

Thanks for the suggestion, I can see the Opencv directory inside the repo but am unable to find path to "pkgconfig" attaching a screenshot for reference.

JaideepK_Intel_0-1691070225805.png

Thanks,

Jaideep

 

0 Kudos
Ruchit_rt
New Contributor I
3,957 Views

Dear jaideep,

using the opencv folder you need build openCV before use.

you can do this following the link https://docs.opencv.org/4.x/d7/d9f/tutorial_linux_install.html . Here are the essential steps, please make sure to make a fresh build repository:-

$ cd opencv

$ rm -rf build

$ mkdir build

$ cd build

$ cmake -D OPENCV_GENERATE_PKGCONFIG=ON -D INSTALL_PYTHON_EXAMPLES=ON -D INSTALL_C_EXAMPLES=ON ..

$ make -j$(nproc)

 

This should install it. The pkg config should be where the opencv4.pc file is. For me this is set as follows:-

echo $PKG_CONFIG_PATH
>>> /home/u196631/opencv_install/lib/pkgconfig

 

Let me know if this lets you help me solve the issue please.

0 Kudos
JaideepK_Intel
Employee
3,923 Views

Hi,

 

I am able to build OpenCV(from github) successfully but unable to get pkgconfig directory (Can you name some files inside the pkgconfig directory so we can debug further) inside OpenCv (need to add this in PKG_CONFIG_PATH as you mentioned above). attaching screenshots for your reference.

JaideepK_Intel_1-1691399779621.png

JaideepK_Intel_0-1691399760445.png

 

 

Thanks,

Jaideep

 

0 Kudos
Ruchit_rt
New Contributor I
3,793 Views

Hi jaideep,

Can you please check this directory:-

/home/jai/opencv_install/lib/pkgconfig

 

this is where the environment variable PKG_CONFIG_PATH needs to point to. It houses the opencv4.pc file. It should have been generated as a result of the installation. If not please check the installaltion process to do the install using this flag '-D OPENCV_GENERATE_PKGCONFIG=ON'

 

Let me know. Thank you

0 Kudos
JaideepK_Intel
Employee
3,778 Views

Hi,

 

I hope you are doing well. We are able to reproduce your issue from our end, attaching screenshots for your reference.

JaideepK_Intel_0-1691735188597.png

JaideepK_Intel_1-1691735299815.png

 

Please let us know if you are getting a similar issue (so we can inform our engineering team) or not.

 

Thanks,

Jaideep

 

0 Kudos
Ruchit_rt
New Contributor I
3,769 Views

Yes Jaideep, 

this is precisely the error that I am facing. Please let me know how to solve this. Thanks

 

0 Kudos
JaideepK_Intel
Employee
3,571 Views

Hi,


Sorry for the delay. We are working on this internally, and we will get back to you with an update.


Thanks,

Jaideep


0 Kudos
JaideepK_Intel
Employee
3,373 Views

Hi,

 

Sorry for the delay. After running the below command, we were able to run your binary successfully, but we observed that your binary was running for more than 24 hours, so the job was terminated.

JaideepK_Intel_1-1694502173420.png

 

JaideepK_Intel_0-1694502006315.png

 

job. sh:

 

#!/bin/bash

source /opt/intel/oneapi/setvars.sh > /dev/null 2>&1

export PKG_CONFIG_PATH=/home/u113485/jai/quar/opencv/build/unix-install:$PKG_CONFIG_PATH

#export QUARTUS_ROOTDIR=/glob/development-tools/versions/intelFPGA_pro/19.2/quartus/

#export QSYS_ROOTDIR=/glob/development-tools/versions/intelFPGA_pro/19.2/qsys/bin



export QUARTUS_ROOTDIR_OVERRIDE=/glob/development-tools/versions/oneapi/2022.3.1/intelFPGA_pro/19.2/quartus

export QUARTUS_PRIME_192=/glob/development-tools/versions/oneapi/2022.3.1/intelFPGA_pro/19.2/quartus



export QUARTUS_PRIME_231=/glob/development-tools/versions/intelFPGA_pro/23.1/quartus
export PATH=$PATH:/glob/intel-python/python2/bin

cd /home/u113485/jai/quar/fgpa_hardware_accelerateNN/

icpx -v -fsycl -fintelfpga -DFPGA_HARDWARE src/model_quantised.cpp -Xshardware -o model_quantised.fpga -Xstarget=intel_s10sx_pac:pac_s10_usm $(pkg-config --cflags --libs opencv4)

 

If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue. Thank you!

 

Regards,

Jaideep

 

0 Kudos
Reply