Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1207 Discussions

Request for CMake >= 3.21.0 for Intel oneAPI NextGen LLVM compiler support

User01
New Contributor II
310 Views

The release notes for CMake 3.20 include the following:

  • The Intel oneAPI NextGen LLVM compilers are now supported with compiler id IntelLLVM:

    • The icx/icpx C/C++ compilers on Linux, and the icx C/C++ compiler on Windows, are fully supported as of oneAPI 2021.1.

    • The ifx Fortran compiler on Linux is supported as of oneAPI 2021.1.

    • The ifx Fortran compiler on Windows is not yet supported.

    The Intel oneAPI Classic compilers (icc, icpc, and ifort) continue to be supported with compiler id Intel.

DevCloud compute nodes have CMake 3.16.3:

$ /usr/bin/cmake --version
cmake version 3.16.3

CMake suite maintained and supported by Kitware (kitware.com/cmake).

They also have the compiler version specifically supported by CMake 3.20:

$ icpx --version
Intel(R) oneAPI DPC++/C++ Compiler 2022.1.0 (2022.1.0.20220316)
Target: x86_64-unknown-linux-gnu
Thread model: posix
InstalledDir: /glob/development-tools/versions/oneapi/2022.2/oneapi/compiler/2022.1.0/linux/bin-llvm

Given that Intel DevCloud exists in part to make it easier to work with the Intel Compiler, upgrading the CMake on the DevCloud would be useful.

As a work-around, I had to install a personal copy of CMake in my $HOME directory to get the new feature.

0 Kudos
1 Solution
AlekhyaV_Intel
Moderator
205 Views

Hi,

 

We got an update from the admin team, We already support cmake 3.21.2. Here's how you can access it:

 

$ module load cmake/3.21.2

 

or

 

$ module load cmake

 

The above works due to the fact that cmake 3.21.2 is the default option for loading the cmake module.

This is how you can verify that the cmake version you want has been loaded:

$ which cmake

/glob/development-tools/versions/cmake/3.21.2/bin/cmake

 

You can check what other cmake versions are available using this command:

$ module avail 

As we have provided a resolution for your request, can we discontinue monitoring this thread?

 

Regards,

Alekhya

 

View solution in original post

4 Replies
User01
New Contributor II
298 Views

Per the Intel Compiler documentation, the required version of CMake is at least 3.21.0 (Use CMake with the Intel® oneAPI DPC++/C++ Compiler).

AlekhyaV_Intel
Moderator
259 Views

Hi Donald,

 

Thank you for sharing your observations with us. We could reproduce your issue. We have forwarded your request to the DevCloud admin team. We will get back to you with an update soon.

 

Regards,

Alekhya

 

AlekhyaV_Intel
Moderator
206 Views

Hi,

 

We got an update from the admin team, We already support cmake 3.21.2. Here's how you can access it:

 

$ module load cmake/3.21.2

 

or

 

$ module load cmake

 

The above works due to the fact that cmake 3.21.2 is the default option for loading the cmake module.

This is how you can verify that the cmake version you want has been loaded:

$ which cmake

/glob/development-tools/versions/cmake/3.21.2/bin/cmake

 

You can check what other cmake versions are available using this command:

$ module avail 

As we have provided a resolution for your request, can we discontinue monitoring this thread?

 

Regards,

Alekhya

 

AlekhyaV_Intel
Moderator
184 Views

Hi,


Thank you for accepting our solution. If you need any further assistance, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Alekhya


Reply