Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JVand22
Beginner
84 Views

Running batch FPGA compile jobs not working (qsub -l nodes=1:fpga_compile:ppn=2 -d . build.sh)

Hello,

I am trying to run FPGA compile jobs as batch jobs using the following command:

qsub -l nodes=1:fpga_compile:ppn=2 -d . build.sh

 where build.sh contains:

#!/bin/bash
source /opt/intel/inteloneapi/setvars.sh
make hw -f Makefile.fpga.
 
The job always finishes in less than a second, with an empty error file (build.sh.eXXXX) and the following output file (build.sh.oXXXX): 

 

########################################################################
# Date: Mon Feb 22 04:45:54 PST 2021
# Job ID: 799108.v-qsvr-1.aidevcloud
# User: u47378
# Resources: neednodes=1:fpga_compile:ppn=2,nodes=1:fpga_compile:ppn=2,walltime=06:00:00
########################################################################

:: WARNING: setvars.sh has already been run. Skipping re-execution.
To force a re-execution of setvars.sh, use the '--force' option.
Using '--force' can result in excessive use of your environment variables.

########################################################################
# End of output for job 799108.v-qsvr-1.aidevcloud
# Date: Mon Feb 22 04:45:59 PST 2021

I am able to run the build.sh script in an interactive session on an fpga_compile node with no problems, but as expected it takes a long time and it would be useful if I could queue multiple batch FPGA compile jobs. 

What am I doing wrong?

Thanks!

 

0 Kudos
1 Reply
AthiraM_Intel
Moderator
55 Views

Hi,

 

Thanks for reaching out to us.

 

Could you please include the path to the working directory (ie, the path to Makefile.fpga) in build.sh

 

build.sh contains:

 

#!/bin/bash

source /opt/intel/inteloneapi/setvars.sh

cd /<path>/

make hw -f Makefile.fpga

 

If the issue still persists, please let us know.

 

 

Thanks.