Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646
720 Discussions

Running batch FPGA compile jobs not working (qsub -l nodes=1:fpga_compile:ppn=2 -d . build.sh)

JVand22
Beginner
412 Views

Hello,

I am trying to run FPGA compile jobs as batch jobs using the following command:

qsub -l nodes=1:fpga_compile:ppn=2 -d . build.sh

 where build.sh contains:

#!/bin/bash
source /opt/intel/inteloneapi/setvars.sh
make hw -f Makefile.fpga.
 
The job always finishes in less than a second, with an empty error file (build.sh.eXXXX) and the following output file (build.sh.oXXXX): 

 

########################################################################
# Date: Mon Feb 22 04:45:54 PST 2021
# Job ID: 799108.v-qsvr-1.aidevcloud
# User: u47378
# Resources: neednodes=1:fpga_compile:ppn=2,nodes=1:fpga_compile:ppn=2,walltime=06:00:00
########################################################################

:: WARNING: setvars.sh has already been run. Skipping re-execution.
To force a re-execution of setvars.sh, use the '--force' option.
Using '--force' can result in excessive use of your environment variables.

########################################################################
# End of output for job 799108.v-qsvr-1.aidevcloud
# Date: Mon Feb 22 04:45:59 PST 2021

I am able to run the build.sh script in an interactive session on an fpga_compile node with no problems, but as expected it takes a long time and it would be useful if I could queue multiple batch FPGA compile jobs. 

What am I doing wrong?

Thanks!

 

0 Kudos
4 Replies
AthiraM_Intel
Moderator
383 Views

Hi,

 

Thanks for reaching out to us.

 

Could you please include the path to the working directory (ie, the path to Makefile.fpga) in build.sh

 

build.sh contains:

 

#!/bin/bash

source /opt/intel/inteloneapi/setvars.sh

cd /<path>/

make hw -f Makefile.fpga

 

If the issue still persists, please let us know.

 

 

Thanks.

 

AthiraM_Intel
Moderator
322 Views

Hi,


Could you please give us an update? Is your issue resolved?


Thanks.


JVand22
Beginner
302 Views

Yes - Adding 'cd <dir>' did the trick, the issue is now resolved.

 

Thanks! 

 

AthiraM_Intel
Moderator
293 Views

Hi,


Thanks for the confirmation. We would discontinue monitoring this issue, please raise a new thread if you have further issues.


Thanks.


Reply