Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1665 Discussions

SSH: connection closed by remote host

astasiak
Employee
2,561 Views

Hi,

I am trying to connect to DevCloud from my corp machine & network, WSL console.

I set up proxy to:

export http_proxy=http://proxy-chain.intel.com:911
export https_proxy=http://proxy-chain.intel.com:911
export ftp_proxy=http://proxy-chain.intel.com:911

 

I did set up the .ssh/config manually, accordingly to the instructions :

Host devcloud
User u172081
IdentityFile ~/.ssh/devcloud-access-key-172081.txt
ProxyCommand ssh -T -i ~/.ssh/devcloud-access-key-172081.txt guest@ssh.devcloud.intel.com

The SSH devcloud key (devcloud-access-key-172081.txt) looks ok.

And, when I am trying to connect:

ssh devcloud

...I am getting:

ssh: connect to host ssh.devcloud.intel.com port 22: Resource temporarily unavailable
kex_exchange_identification: Connection closed by remote host

 

I tried with set proxy (at the beginning on my post) and without setting it.

Any solution?

Thank you. /A.

0 Kudos
1 Solution
astasiak
Employee
2,520 Views

[SOLVED]

Hi,

I followed You recommendation, thx. The script generated the same config that I have created manually.

But it was worth for double check... And it pointed me to look much closely at the proxy serwer.... and that was good direction.

 

The problem was with chosen proxy serwer for SSH connection going outside Intel proxy;

>>this does not work: ProxyCommand nc -x proxy-chain.intel.com:911 %h %p

>>(success) this works: ProxyCommand nc -x proxy-socks.jf.intel.com:1080 %h %p

 

Thank you. /Andrzej.

View solution in original post

3 Replies
RemyaP_Intel
Moderator
2,530 Views

Hi,

 

Thank you for posting in Intel communities.

 

Please follow the steps for automatic configuration(option 1) given in this link.

 

When the script is executed in your terminal you can find a configuration file created ~/.ssh/config. You need to edit this config file with the respective HOSTNAME and PORT at the highlighted.

RemyaP_Intel_0-1669016073788.png

 

After the above steps, you should be able to log in to Intel DevCloud using the command

ssh devcloud.proxy

 

If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue. Thank you!

 

 

Regards,

Remya Premdas

 

 

astasiak
Employee
2,521 Views

[SOLVED]

Hi,

I followed You recommendation, thx. The script generated the same config that I have created manually.

But it was worth for double check... And it pointed me to look much closely at the proxy serwer.... and that was good direction.

 

The problem was with chosen proxy serwer for SSH connection going outside Intel proxy;

>>this does not work: ProxyCommand nc -x proxy-chain.intel.com:911 %h %p

>>(success) this works: ProxyCommand nc -x proxy-socks.jf.intel.com:1080 %h %p

 

Thank you. /Andrzej.

RemyaP_Intel
Moderator
2,508 Views

Hi,


Thanks for accepting our solution. Glad to know that your issue is resolved.


If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Remya Premdas


Reply