Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1692 Discussions

Unabble to access Intel Devcloud with ssh

Serafina
Beginner
1,653 Views

Hi,

I created my account for the devcloud yesterday and I tried to access the cloud after launching the script for the automatic ssh configuration,

but using the standard command:

ssh -v devcloud

I got this error:
OpenSSH_7.6p1 Ubuntu-4ubuntu0.6, OpenSSL 1.0.2n 7 Dec 2017
debug1: Reading configuration data /home/serafina/.ssh/config
debug1: /home/serafina/.ssh/config line 23: Applying options for devcloud
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Executing proxy command: exec ssh -T -i ~/.ssh/devcloud-access-key-159897.txt guest@ssh.devcloud.intel.com
debug1: key_load_public: No such file or directory
debug1: identity file /home/serafina/.ssh/devcloud-access-key-159897.txt type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/serafina/.ssh/devcloud-access-key-159897.txt-cert type -1
debug1: permanently_drop_suid: 1000
debug1: Local version string SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.6
Received disconnect from 12.229.61.118 port 22:2: Too many authentication failures
Disconnected from 12.229.61.118 port 22
ssh_exchange_identification: Connection closed by remote host

Then I tried the command below:

(base) serafina@serafina-N501VW:~$ ssh -v -XY -o IdentitiesOnly=yes -T -i /home/serafina/.ssh/devcloud-access-key-159897.txt guest@ssh.devcloud.intel.com
OpenSSH_7.6p1 Ubuntu-4ubuntu0.6, OpenSSL 1.0.2n 7 Dec 2017
debug1: Reading configuration data /home/serafina/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to ssh.devcloud.intel.com [12.229.61.118] port 22.
debug1: Connection established.
debug1: key_load_public: No such file or directory
debug1: identity file /home/serafina/.ssh/devcloud-access-key-159897.txt type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/serafina/.ssh/devcloud-access-key-159897.txt-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.6
debug1: Remote protocol version 2.0, remote software version OpenSSH_8.2p1 Ubuntu-4ubuntu0.5
debug1: match: OpenSSH_8.2p1 Ubuntu-4ubuntu0.5 pat OpenSSH* compat 0x04000000
debug1: Authenticating to ssh.devcloud.intel.com:22 as 'guest'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:fdh1CzIao2MCh6YQ3uP7ZZyZF0XqieU7OY6DjcDctq4
debug1: Host 'ssh.devcloud.intel.com' is known and matches the ECDSA host key.
debug1: Found key in /home/serafina/.ssh/known_hosts:1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,sk-ssh-ed25519@openssh.com,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,sk-ecdsa-sha2-nistp256@openssh.com>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/serafina/.ssh/devcloud-access-key-159897.txt
debug1: Authentication succeeded (publickey).
Authenticated to ssh.devcloud.intel.com ([12.229.61.118]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: pledge: exec
debug1: client_input_global_request: rtype hostkeys-00@openssh.com want_reply 0
debug1: Remote: /opt/ssh/getkey %f:1: key options: agent-forwarding command permitopen port-forwarding pty user-rc x11-forwarding
Warning: No xauth data; using fake authentication data for X11 forwarding.
debug1: Requesting X11 forwarding with authentication spoofing.
debug1: Sending environment.
debug1: Sending env LANG = it_IT.UTF-8
SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.3

 

But it got stalled.

Can it depend on the settings that I have in the /etc/ssh/ssh_config?

 

I attached this file (as ssh_config.txt) so you can have a look at it.

 

I would really appreciate any help.

 

Thank you in advance,

Serafina

 

0 Kudos
11 Replies
RemyaP_Intel
Employee
1,633 Views

Hi,


Thank you for posting in Intel Communities.


Your issue might be due to corrupted ssh key. So, you can download the "devcloud-access-key-xxxxxx.txt" file again and try connecting to devcloud. 


If your key is not corrupted, make use of the same key to login to devcloud server. For that follow the below steps:


1. Delete the existing .ssh directory.

      rm -r ~/.ssh


2. Create a new ~/.ssh directory, and move the private SSH key into permanent storage in ~/.ssh as follows:

      mkdir -p ~/.ssh

      mv <path to downloaded key>/devcloud-access-key-xxxxxx.txt ~/.ssh/


3. Create the config file again in ~/.ssh folder as mentioned in the documentation(https://devcloud.intel.com/oneapi/documentation/connect-with-ssh-linux-macos/)


4. Manually verify whether the key file is present in the ~/.ssh folder and set correct permissions as below:        

      chmod 600 ~/.ssh/devcloud-access-key-xxxxxx.txt

      chmod 600 ~/.ssh/config


The above steps are from the Manual Configuration of devcloud connection documentation. For further reference : https://devcloud.intel.com/oneapi/documentation/connect-with-ssh-linux-macos/


[Note : Please make sure that the correct path and name of the key is provided in the config file.]



Try the above steps and if the issue persist please let us know.



Regards,

Remya Premdas



0 Kudos
Serafina
Beginner
1,615 Views

Hi, I tried your suggestion,

and I have canceled everything in the dir .ssh, leaving only the public key downloaded from the intel website,

but still I am not able to access the devcloud .

If I run the command:

ssh -v devcloud

 

I got the output:

 

OpenSSH_7.6p1 Ubuntu-4ubuntu0.6, OpenSSL 1.0.2n 7 Dec 2017
debug1: Reading configuration data /home/serafina/.ssh/config
debug1: /home/serafina/.ssh/config line 1: Applying options for devcloud
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Executing proxy command: exec ssh -T -i ~/.ssh/devcloud-access-key-159897.txt guest@ssh.devcloud.intel.com
debug1: permanently_drop_suid: 1000
debug1: key_load_public: No such file or directory
debug1: identity file /home/serafina/.ssh/devcloud-access-key-159897.txt type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/serafina/.ssh/devcloud-access-key-159897.txt-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.6
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.6p1 Ubuntu-4ubuntu0.3
debug1: match: OpenSSH_7.6p1 Ubuntu-4ubuntu0.3 pat OpenSSH* compat 0x04000000
debug1: Authenticating to devcloud:22 as 'u159897'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:7R/nUuhf2mWQej8YRr+FNr0T0++Rw71wmvZpsrysbFU
debug1: Host 'devcloud' is known and matches the ECDSA host key.
debug1: Found key in /home/serafina/.ssh/known_hosts:3
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/serafina/.ssh/devcloud-access-key-159897.txt
debug1: Authentications that can continue: publickey
debug1: No more authentication methods to try.
u159897@devcloud: Permission denied (publickey).

 

 

Can it be due to some configuration setting that I have in the file /etc/ssh/ssh_config ?

I attached below a screenshot of the content of this file.

 

Thank you for your time,

Best regards,

Serafina

0 Kudos
RemyaP_Intel
Employee
1,604 Views

Hi,


We are working on this. We will get back to you soon.


Regards,

Remya Premdas


0 Kudos
RemyaP_Intel
Employee
1,566 Views

Hi,


The public key permission denied error was due to a bug on the web portal SSO introduced Thursday July 14th at ~1pm and resolved at ~10am July 15th. In fixing this bug, if you are still getting this error, please down load the public key as shown in the credentials email



Regards,

Remya Premdas


0 Kudos
fcharras
Beginner
1,557 Views

Hi Remya,

I'm still unable to connect. Downloading the ssh key again does not help, the file is the same than before.

Could you maybe reset my user (u160428) so I can get a new, not bugged ssh key ?

Thanks in advance

fcharras

0 Kudos
ogrisel
Beginner
1,551 Views

I have the exact same problem (my username is `u155032`). I redownloaded and re-run the ssh setup script after having deleted my previous key and config. I still get:

 

```

$ ssh devcloud
u155032@devcloud: Permission denied (publickey).

```

0 Kudos
RemyaP_Intel
Employee
1,535 Views

Hi,


Sorry to keep you waiting. We have informed devcloud admin team. They are looking into the issue. 


Regards,

Remya Premdas


0 Kudos
RemyaP_Intel
Employee
1,509 Views

Hi Serafina,


We received an update that your issue has been resolved. Could you please check and confirm us.


--

Regards,

Remya Premdas


0 Kudos
RemyaP_Intel
Employee
1,427 Views

Hi,

 

Is the issue resolved? Could you please give us an update.


0 Kudos
ogrisel
Beginner
1,376 Views

The issue was resolved for my account. Thank you very much!

 

0 Kudos
RemyaP_Intel
Employee
1,365 Views

Hi Serafina,

 

Glad to know your issue is resolved. This thread will no longer be monitored by Intel. If you need further assistance, please post a new question.

 

Regards,

Remya Premdas

 

0 Kudos
Reply