Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1596 Discussions

VScode connection to devcloud drops from time to time

Scarlet1ssimo
Beginner
560 Views

As title.

The ssh connection to devcloud is unstable and drops every ~5 minutes, even when there was active activity. Also I noticed there was an option devcloud-vscode, but it never connects.

Any idea how to get a stable connection to devcloud on vscode?

 

0 Kudos
4 Replies
AthiraM_Intel
Moderator
507 Views

Hi,


Thank you for posting in Intel Community.


We tried to replicate the issue from our side and could not observe any connectivity issues while using VSCode. 


Could you please add the below command in the ssh config file to keep the connection alive and try once again:


Host *

  ServerAliveInterval 60

If the issue still persists, please share the config file.



>> Also I noticed there was an option devcloud-vscode, but it never connects.


Could you please let us know the error you are facing, also share the screenshot for the same.


Kindly follow the below documentation to verify if the DevCloud VSCode connection is configured correctly:

https://devcloud.intel.com/oneapi/documentation/connect-with-vscode/



Thanks


0 Kudos
Scarlet1ssimo
Beginner
472 Views

Thanks for your reply so much!

I tried ServerAliveInterval 60, and it looks good to me so far.

 

 

---------

For devcloud-vscode, I followed the instruction in https://devcloud.intel.com/oneapi/documentation/connect-with-vscode/

But I failed while connecting to node. 

Here are my screenshots and ssh config. 

Note: I'm connecting directly, without proxy. Please correct me if I made something wrong.

# On devcloud
u208523@login-2:~$ qsub public.sh
2447264.v-qsvr-1.aidevcloud
u208523@login-2:~$ qstat -n -1

v-qsvr-1.aidevcloud:
Req'd Req'd Elap
Job ID Username Queue Jobname SessID NDS TSK Memory Time S Time
----------------------- ----------- -------- ---------------- ------ ----- ------ --------- --------- - ---------
2447264.v-qsvr-1.aidev u208523 batch public.sh 604608 1 2 -- 75:00:00 R -- s001-n059/0-1
# On my local shell
> ssh 2447264.v-qsvr-1.aidevcloud -v
OpenSSH_8.9p1 Ubuntu-3ubuntu0.4, OpenSSL 3.0.2 15 Mar 2022
debug1: Reading configuration data /home/scarlet/.ssh/config
debug1: /home/scarlet/.ssh/config line 11: Applying options for *
debug1: /home/scarlet/.ssh/config line 53: Applying options for *.aidevcloud
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: include /etc/ssh/ssh_config.d/*.conf matched no files
debug1: /etc/ssh/ssh_config line 21: Applying options for *
debug1: Executing proxy command: exec ssh -T devcloud nc 2447264.v-qsvr-1.aidevcloud 22
debug1: identity file /home/scarlet/.ssh/devcloud-access-key-208523.txt type 0
debug1: identity file /home/scarlet/.ssh/devcloud-access-key-208523.txt-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_8.9p1 Ubuntu-3ubuntu0.4
nc: getaddrinfo for host "2447264.v-qsvr-1.aidevcloud" port 22: Name or service not known
kex_exchange_identification: Connection closed by remote host
Connection closed by UNKNOWN port 65535

 And hopefully related ssh config.

################################################################################################
# oneAPI DevCloud SSH config
################################################################################################
Host devcloud
    User u208523
    IdentityFile ~/.ssh/devcloud-access-key-208523.txt
    ProxyCommand ssh -T -i ~/.ssh/devcloud-access-key-208523.txt guest@ssh.devcloud.intel.com

Host devcloud.proxy
    User u208523
    Port 4022
    IdentityFile ~/.ssh/devcloud-access-key-208523.txt
    ProxyCommand ssh -T devcloud-via-proxy

# If you must route outgoing SSH connection via a corporate proxy,
# replace PROXY_HOSTNAME and PORT below with the values provided by
# your network administrator.
Host devcloud-via-proxy
    User guest
    Hostname ssh.devcloud.intel.com
    IdentityFile ~/.ssh/devcloud-access-key-208523.txt
    LocalForward 4022 c009:22
    ProxyCommand nc -x PROXY_HOSTNAME:PORT %h %p
################################################################################################

################################################################################################
# DevCloud VSCode config
################################################################################################
Host devcloud-vscode
    UserKnownHostsFile /dev/null
    StrictHostKeyChecking no
    Hostname localhost
    User u208523
    Port 5022
    IdentityFile ~/.ssh/devcloud-access-key-208523.txt
################################################################################################

################################################################################################
# SSH Tunnel config
################################################################################################
Host *.aidevcloud
    User u208523
    IdentityFile ~/.ssh/devcloud-access-key-208523.txt
    ProxyCommand ssh -T devcloud nc %h %p
    LocalForward 5022 localhost:22
    LocalForward 5901 localhost:5901
################################################################################################

 

0 Kudos
Scarlet1ssimo
Beginner
427 Views

I fixed the issue following steps here.

https://community.intel.com/t5/Intel-DevCloud/Problem-with-connect-devcloud-vscode/m-p/1260350

 

(It's just I thought I should ssh to 2447264.v-qsvr-1.aidevcloud but in fact I need to ssh to s001-n059.aidevcloud)

 

Proof of success

Scarlet1ssimo_0-1702628695083.png

 

0 Kudos
AthiraM_Intel
Moderator
415 Views

Hi,


Glad to know that your issue is resolved. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Thanks


0 Kudos
Reply