Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
998 Discussions

devcloud connection problems

singaravelann
Employee
545 Views

When I tried to connect to devcloud from my labtop with Cygwin, I see this err.

ssh: connect to host ssh.devcloud.intel.com port 22: Connection timed out
kex_exchange_identification: Connection closed by remote host
Connection closed by UNKNOWN port 65535

0 Kudos
6 Replies
AthiraM_Intel
Moderator
522 Views

Hi,


Thanks for reaching out to us.


Are you connecting DevCloud for the first time?

Please share your config file.


Also try replacing all instances of devcloud.intel.com with ssh.devcloud.intel.com in your ~/.ssh/config file and let us know if that works.



Thanks.




singaravelann
Employee
519 Views

Here is my .ssh/config

 

################################################################################################
# oneAPI DevCloud SSH config
################################################################################################
Host devcloud
User u84057
IdentityFile ~/.ssh/devcloud-access-key-84057.txt
ProxyCommand ssh -T -i ~/.ssh/devcloud-access-key-84057.txt guest@ssh.devcloud.intel.com

Host devcloud.proxy
User u84057
Port 4022
IdentityFile ~/.ssh/devcloud-access-key-84057.txt
ProxyCommand ssh -T devcloud-via-proxy

# If you must route outgoing SSH connection via a corporate proxy,
# replace PROXY_HOSTNAME and PORT below with the values provided by
# your network administrator.
Host devcloud-via-proxy
User guest
Hostname ssh.devcloud.intel.com
IdentityFile ~/.ssh/devcloud-access-key-84057.txt
LocalForward 4022 c009:22
ProxyCommand nc -x proxy-iind.intel.com:911 %h %p
################################################################################

GRN2
Employee
502 Views

Hi,

Turn off VPN and try again.

AthiraM_Intel
Moderator
461 Views

Hi singaravelann,



Could you please replace your ProxyCommand by the following one


ProxyCommand nc -x proxy-iind.intel.com %h %p


This is for connecting DevCloud via proxy using the command "ssh devcloud.proxy"


You can also disconnect the vpn and connect DevCloud by using "ssh devcloud" which will also work.


Hope this helps. If the issue still persists, please let us know.


Thanks


singaravelann
Employee
444 Views

Hi, 

It worked after turning off VPN.

 

Thanks for the support.

AthiraM_Intel
Moderator
430 Views

Hi,


Glad to know that your issue is resolved. If you need any additional information, please submit a new question as this thread will no longer be monitored.



Thanks.



Reply