Community
cancel
Showing results for 
Search instead for 
Did you mean: 
W_E_Intel
Employee
848 Views

getquota is not working

Jump to solution

hello,

When I execute getquota I receive the following error,

curl: (7) Failed to connect to login-X port XXX : No route to host

please help to resolve the error ?

thank you,

0 Kudos
1 Solution
Dan_P_Intel
Employee
586 Views

I'm going to check whether getquota is supposed to work on a compute node. 

In the meantime, please try one of these workarounds:

1. run on the login-2 node

2. if on Jupyter you need to connect to the login-2 node. by default you're on a compute node so it's not going to work. please do this:

$ ssh login-2
$ getquota
$ exit

This is what this looks like on my Jupyter connection:

s001-n047:~
$ ssh login-2

login-2:~
$ getquota
9.09 GB out of 200.00 GB (4.54%) used

login-2:~
$ exit

View solution in original post

13 Replies
ChithraJ_Intel
Moderator
835 Views

Hi Wessam,


Thanks for reaching out to us. We have also observed similar issue while executing getquota command and will inform the concerned team regarding this issue. As a workaround, you can use the below commands to check the available free space.

  • To check the available free space and utilization use the below command.

df -h

  • To analyze detailed disk utilization by each folder, run the below command.

du -sh *

du -sh <folder_name/filename>


Regards,

Chithra


W_E_Intel
Employee
777 Views

any updates, the command is not working ?

W_E_Intel
Employee
762 Views

Hello Chithra

du dose not help to know the remain storage on the drive space, can you help find alternative way to resolve this problem if getquota is not be available soon ?

thank you,

Wessam

ChithraJ_Intel
Moderator
753 Views

Hi Wessam,


Sorry for the delay. We will check with the admin team and let you know the updates soon.


Regards,

Chithra


ChithraJ_Intel
Moderator
729 Views

Hi Wessam,


Sorry for the delay. This is being worked on along with other infrastructure improvements. We will update the status soon.


Regards,

Chithra



ChithraJ_Intel
Moderator
664 Views

Hi Wessam,


Sorry for the delay in replying. The issue with getquota command is resolved in Devcloud login node. Now, you can try running the command to get the disk space usage. Could you please verify it and please let us know whether we can discontinue monitoring the thread?


Regards,

Chithra


ChithraJ_Intel
Moderator
632 Views

Hi Wessam,


We didn't heard back anything from you. We are assuming that the issue got resolved and would no longer be monitoring this issue. Please raise a new thread if you have further issues.


Regards,

Chithra


W_E_Intel
Employee
617 Views

hello Chithra

getquota is not working, still give same error 

"curl: (7) Failed to connect to login-1 port 898: No route to host."

thank you,

W

George_S_Intel
Employee
607 Views

Hello @W_E_Intel if you connect in the login node in DevCloud the command getquota works.

It fails if you are using one of the computing node. The login node is the first node that you connect when using ssh connection. If you are connecting in DevCloud through Jupyter Notebook, you might not be able to connect to the login node.

In the computing node (or from Jupyter notebook) you should be able to use the workaround presented in this thread.

__
George H Silva

W_E_Intel
Employee
598 Views

it is not working !

Dan_P_Intel
Employee
587 Views

I'm going to check whether getquota is supposed to work on a compute node. 

In the meantime, please try one of these workarounds:

1. run on the login-2 node

2. if on Jupyter you need to connect to the login-2 node. by default you're on a compute node so it's not going to work. please do this:

$ ssh login-2
$ getquota
$ exit

This is what this looks like on my Jupyter connection:

s001-n047:~
$ ssh login-2

login-2:~
$ getquota
9.09 GB out of 200.00 GB (4.54%) used

login-2:~
$ exit

View solution in original post

Dan_P_Intel
Employee
583 Views

We just enabled getquota on the compute nodes as well.

Let us know if you find any issues.

Thanks again for reporting!

Dan

W_E_Intel
Employee
575 Views

Thanks Dan, it works !

Reply