Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud

'pip' not found

ThiagoFilipe
Novice
1,020 Views

Yesterday 'pip' was OK, but today the OS doesn't seem to be able to find it (see attached picture). Some packages I've installed previously seem to be gone, and I can't install them back without 'pip'. Please, help!

0 Kudos
7 Replies
ThiagoFilipe
Novice
1,017 Views

Also, 'permission denied' when trying to install 'pip' via 'apt install python3-pip', as suggested in the screenshot.

ThiagoFilipe
Novice
929 Views

Anyone?

The packages I've installed previously are simply gone, and I can't install them back without 'pip'. So I'm completely blocked because of this issue

 

I don't seem to be able to do anything about it since I don't have root permissions!

AthiraM_Intel
Moderator
889 Views

Hi,


Thank you for posting in Intel Communities.


Could you please try to install pip using any other alternatives which do not need sudo permission.


For example, you can use conda. please find the below command to install pip:


conda install -c anaconda pip


Also you can use oneapi environment, where pip is already installed. You can activate oneapi environment using the below command:


source /opt/intel/oneapi/setvars.sh --force


For your information, user's don't have have root permission in DevCloud.


Hope this helps. If you have any further issue, please let us know.



Thanks.


ThiagoFilipe
Novice
839 Views

Thanks! This solution works:

 

source /opt/intel/oneapi/setvars.sh --force

 

I'm wondering why is this happening now, it doesn't seem to be affecting other users. This solution works but since I have to 'ssh' into a machine every time I need to run something, I also need to run this command and reinstall the packages every time. Do you have any idea why this might be happening?

AthiraM_Intel
Moderator
816 Views

Hi,

 

Glad to know that the solution provided helped.

 

You can use the oneAPI environment as default by setting the 'source /opt/intel/inteloneapi/setvars.sh' command in the bash_profile.

 

Please follow the below steps:

 

vi ~/.bash_profile

 

Add and save the source command in the file.

source /opt/intel/inteloneapi/setvars.sh --force
source ~/.bash_profile

 

Regarding the issue "reinstall the packages every time" ,you can create a conda environment and install all the packages there. Please follow the below steps:

 

Step 1 : Create conda environment

 

conda create -n <env_name> python=<version>

 

Step 2 : Activate conda environment

 

conda activate <env_name>

 

Step3 : Install packages you want

 

conda install <package>

 

You can activate this environment after login to DevCloud.

 

Hope this helps. If you face any issue please let us know.

 

 

 

Thanks

 

AthiraM_Intel
Moderator
685 Views

Hi,


Has the solution provided helped? Could you please give us an update?



Thanks.


AthiraM_Intel
Moderator
621 Views

Hi,


I assume that your issue is resolved. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel. 



Thanks.



Reply