Intel® DevCloud
Help for those needing help starting or connecting to the Intel® DevCloud
1661 Discussions

ssh connection failure to devcloud via windows powershell

NUMBER623
Beginner
2,872 Views

I tried to make an ssh connection to devcloud with Windows powershell, but got the following error

 

u192643@devcloud: Permission denied (publickey).

 

The following is a log of ssh with the -v option. Is there a solution to this problem?

 

PS C:\Users\r00433147\.ssh> ssh -v devcloud
OpenSSH_for_Windows_8.1p1, LibreSSL 3.0.2
debug1: Reading configuration data C:\\Users\\r00433147/.ssh/config
debug1: C:\\Users\\r00433147/.ssh/config line 1: Applying options for devcloud
debug1: Executing proxy command: exec ssh -vT -i ~/.ssh/devcloud-access-key-192643.txt guest@ssh.devcloud.intel.com
debug1: identity file C:\\Users\\r00433147/.ssh/devcloud-access-key-192643.txt type -1
debug1: identity file C:\\Users\\r00433147/.ssh/devcloud-access-key-192643.txt-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_for_Windows_8.1
OpenSSH_for_Windows_8.1p1, LibreSSL 3.0.2
debug1: Reading configuration data C:\\Users\\r00433147/.ssh/config
debug1: Connecting to ssh.devcloud.intel.com [12.229.61.118] port 22.
debug1: Connection established.
debug1: identity file C:\\Users\\r00433147/.ssh/devcloud-access-key-192643.txt type -1
debug1: identity file C:\\Users\\r00433147/.ssh/devcloud-access-key-192643.txt-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_for_Windows_8.1
debug1: Remote protocol version 2.0, remote software version OpenSSH_8.2p1 Ubuntu-4ubuntu0.5
debug1: match: OpenSSH_8.2p1 Ubuntu-4ubuntu0.5 pat OpenSSH* compat 0x04000000
debug1: Authenticating to ssh.devcloud.intel.com:22 as 'guest'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:fdh1CzIao2MCh6YQ3uP7ZZyZF0XqieU7OY6DjcDctq4
debug1: Host 'ssh.devcloud.intel.com' is known and matches the ECDSA host key.
debug1: Found key in C:\\Users\\r00433147/.ssh/known_hosts:2
debug1: rekey out after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey in after 134217728 blocks
debug1: pubkey_prepare: ssh_get_authentication_socket: No such file or directory
debug1: Will attempt key: C:\\Users\\r00433147/.ssh/devcloud-access-key-192643.txt explicit
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,sk-ssh-ed25519@openssh.com,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,sk-ecdsa-sha2-nistp256@openssh.com>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: C:\\Users\\r00433147/.ssh/devcloud-access-key-192643.txt
debug1: Authentication succeeded (publickey).
Authenticated to ssh.devcloud.intel.com ([12.229.61.118]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: pledge: network
debug1: client_input_global_request: rtype hostkeys-00@openssh.com want_reply 0
debug1: Remote: /opt/ssh/getkey %f:1: key options: agent-forwarding command permitopen port-forwarding pty user-rc x11-forwarding
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.6p1 Ubuntu-4ubuntu0.3
debug1: match: OpenSSH_7.6p1 Ubuntu-4ubuntu0.3 pat OpenSSH_7.0*,OpenSSH_7.1*,OpenSSH_7.2*,OpenSSH_7.3*,OpenSSH_7.4*,OpenSSH_7.5*,OpenSSH_7.6*,OpenSSH_7.7* compat 0x04000002
debug1: Authenticating to devcloud:22 as 'u192643'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:7R/nUuhf2mWQej8YRr+FNr0T0++Rw71wmvZpsrysbFU
debug1: Host 'devcloud' is known and matches the ECDSA host key.
debug1: Found key in C:\\Users\\r00433147/.ssh/known_hosts:3
debug1: rekey out after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey in after 134217728 blocks
debug1: pubkey_prepare: ssh_get_authentication_socket: No such file or directory
debug1: Will attempt key: C:\\Users\\r00433147/.ssh/devcloud-access-key-192643.txt explicit
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: C:\\Users\\r00433147/.ssh/devcloud-access-key-192643.txt
debug1: Authentications that can continue: publickey
debug1: No more authentication methods to try.
u192643@devcloud: Permission denied (publickey).

0 Kudos
14 Replies
RajashekarK_Intel
Moderator
2,846 Views

Hi, Thanks for posting in Intel Communities.

 

I hope you are following the connectivity guide and your config file has the valid content

( https://devcloud.intel.com/oneapi/documentation/connect-with-ssh-windows-openssh/#:~:text=Create%20a%20text%20file%20called%20config%20without%20the%20.txt%20extension%20and%20add%20the%20following%20lines%20to%20it%3A ).

 

Make sure you have appropriate permissions to the .ssh directory and to files present in it which includes config and DevCloud access key, if you are unsure, The easier way is to delete the directory(.ssh) and create again.

 

If the issue still persists, please check whether you are able to access JupyterLab and let us know.

Access JupyterLab from here (Get Started | Intel® DevCloud)

Jupyter_lab.png

 

 

Regards,

Rajashekar

 

0 Kudos
NUMBER623
Beginner
2,811 Views

Hi Rajashekar,

Thank you for your reply.

 

I deleted the .ssh and tried again, but the result was the same.

I also tried an ssh connection via another Linux machine with the same result.


I can access JupyterLab with no problem.

 

 

Regards,

Mutsumi Namba (NUMBER623)

0 Kudos
RajashekarK_Intel
Moderator
2,786 Views

Hi,

I hope you are accessing the devcloud-access-key in a correct way from config file and make sure you download the latest one and re-configure it, In order to debug your issue further please share your config file.

It would be great if you provide one more information that if are you on a proxy network or open internet?


Regards,

Rajashekar


0 Kudos
NUMBER623
Beginner
2,745 Views

Hi,

I have attached the config file. Also, the connection does not use proxy.


Regards,

Mutsumi Namba (NUMBER623)

 

0 Kudos
RajashekarK_Intel
Moderator
2,672 Views

Hi, Thank you for the response.


Can you try the same thing from Command prompt instead of powershell and check, If even that doesn't work, can you try to create a new account and check whether you are able to access via SSH through CMD.

https://devcloud.intel.com/oneapi/documentation/connect-with-ssh-windows-openssh/, make sure you check the dependencies section even if they are applicable to you.


Regards,

Rajashekar



0 Kudos
NUMBER623
Beginner
2,547 Views

Hi,

 

Both the results of the command prompt and the attempt to create a new account were the same as before.
Since the connection is not via proxy, I see no particular problem with the dependency.

 

Regards,

Namba

0 Kudos
RajashekarK_Intel
Moderator
2,497 Views

Hi,

We have sent you an email to the account which is registered on DevCloud, Please follow the instructions carefully and let us know if you are still facing issue.


Regards,

Rajashekar


0 Kudos
RajashekarK_Intel
Moderator
2,403 Views

Hi, Good day to you.


We have not heard back from you. Is your issue resolved with the given solution? If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue.


Regards,

Rajashekar


0 Kudos
NUMBER623
Beginner
2,376 Views

Hi

I tried to connect with the file you sent me separately by email and got the following error.

 

C:\Users\r00433147>ssh -v devcloud

OpenSSH_for_Windows_8.1p1, LibreSSL 3.0.2

debug1: Reading configuration data C:\\Users\\r00433147/.ssh/config

debug1: C:\\Users\\r00433147/.ssh/config line 1: Applying options for devcloud

debug1: Executing proxy command: exec ssh -T -i ~/.ssh/u192643.txt guest@ssh.devcloud.intel.com

debug1: identity file C:\\Users\\r00433147/.ssh/u192643.txt type -1

debug1: identity file C:\\Users\\r00433147/.ssh/u192643.txt-cert type -1

debug1: Local version string SSH-2.0-OpenSSH_for_Windows_8.1

Load key "C:\\Users\\r00433147/.ssh/u192643.txt": invalid format

guest@ssh.devcloud.intel.com: Permission denied (publickey).

kex_exchange_identification: Connection closed by remote host

 

Regards,

Namba

0 Kudos
RajashekarK_Intel
Moderator
2,327 Views

Hi,

We've sent you a new email with key and steps to follow, as the old key might've got corrupted again! Please follow the instructions accordingly, Let us know if you are still facing issue.

 

Regards,

Rajashekar

 

0 Kudos
NUMBER623
Beginner
2,200 Views

Hi,

Thank you for sending new file.

The file you resent was identical in content to the file before it. Therefore, the same phenomenon occurs as before and the connection is still not established.

 

Regards,

Namba

0 Kudos
RajashekarK_Intel
Moderator
2,166 Views

Hi,

Thanks for your patience. As we look closely into your issue, we observed the error "invalid format". It does seem that there is something wrong with, how the key is dealt on Windows and there's an issue on GitHub with the similar thing ( https://github.com/PowerShell/Win32-OpenSSH/issues/1315 ).

 

  1. I recommend you to follow the workaround given here "https://github.com/PowerShell/Win32-OpenSSH/issues/1315#:~:text=id_rsa%22%3A%20invalid%20format-,Workaround,-Open%20the%20file".
  2. Try to connect on Linux with the key sent and send your log error.
  3. Provide the userID of the new DevCloud account you created earlier.

 

Let us know if you are still facing the issue, even after trying steps 1&2.

 

Regards,

Rajashekar

 

0 Kudos
RajashekarK_Intel
Moderator
2,076 Views

Hi, Good day to you.


We have not heard back from you. Is your issue resolved with the given solution? If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue.


Regards,

Rajashekar


0 Kudos
RajashekarK_Intel
Moderator
2,002 Views

Hi,

We assume that your issue is resolved. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Rajashekar


0 Kudos
Reply