Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
270 Views

Packages in Conda are outdated

I noticed that almost all python packages are outdated in conda, and I have to update them my self while using the notebooks. Is there a possibility where they just keep the packages updated for us?

0 Kudos
7 Replies
Highlighted
Moderator
270 Views

Hi,

Thanks for reaching out to us.

Are you using intel channel to download the packages?

Also, could you please share few packages that you tried to install.

0 Kudos
Highlighted
Moderator
270 Views

Hi,

Could you please share the above mentioned details.

 

Thanks

0 Kudos
Highlighted
Beginner
270 Views

Hi,

Sorry for the late response. Yes I used the Intel channel to download.
I tried installing torchvision and torch, and after it did, I couldn't import torchvision because
the required version of PIL was 7.0 and Intel has 4.0.

Thanks.

0 Kudos
Highlighted
Moderator
270 Views

Hi,

We are forwarding this case to Engineering team.

 

Thanks

 

0 Kudos
Highlighted
Beginner
270 Views

Hi,

Thanks

0 Kudos
Highlighted
Employee
270 Views

Hi Martin

This is Ying from Intel python support team. Thank you a lot for your reports. we also noticed the issues for a while.   It may be  because Intel python own one old validation matrix and release product . so  keep old one.  We released a new version 2020.1 recently. you are welcomed to try it.   

We will try our best to keep the version with latest version. 

Thanks

Ying

0 Kudos
Highlighted
Employee
248 Views

Dear all, 

We have new version 2020 update 2 release in conda  repo , where we update the package version. If possible, please try it and let us know if any issues. 

https://anaconda.org/intel/repo

About the PIL and PyTorch problem here,  as intel contribute  pytorch by pyTorch channel directly.  so we just  use the PyTorch channel by default .   I suggest to use  

>conda install pytorch torchvision cudatoolkit=10.2 -c pytorch

to install pytorch. 

for example, i try today, 

(base) yhu5@clx01:~/Desktop$ conda install pytorch torchvision cudatoolkit=10.2 -c pytorch
Collecting package metadata (current_repodata.json): done
Solving environment: done
## Package Plan ##
  environment location: /home/yhu5/intelpython3_2020/intelpython3
  added / updated specs:
    - cudatoolkit=10.2
    - pytorch
    - torchvision

The following packages will be downloaded:
    package                    |            build
    ---------------------------|-----------------
    blas-1.0                   |              mkl           6 KB 
    cudatoolkit-10.2.89        |       hfd86e86_1       365.1 MB
    libtiff-4.1.0              |       hc7e4089_6         668 KB  
    libwebp-base-1.1.0         |       h516909a_3         845 KB  
    ninja-1.10.0               |       hc9558a2_0         1.9 MB  
    olefile-0.46               |             py_0          31 KB  
    pillow-6.2.1               |   py37hd70f55b_1         632 KB  
    pytorch-1.5.1              |py3.7_cuda10.2.89_cudnn7.6.5_0       424.3 MB  pytorch
    torchvision-0.6.1          |       py37_cu102        11.7 MB  pytorch
    ------------------------------------------------------------
                                           Total:       805.2 MB
The following NEW packages will be INSTALLED:
  blas               anaconda/pkgs/free/linux-64::blas-1.0-mkl
  cudatoolkit        pkgs/main/linux-64::cudatoolkit-10.2.89-hfd86e86_1
  libtiff            anaconda/cloud/conda-forge/linux-64::libtiff-4.1.0-hc7e4089_6
  libwebp-base       anaconda/cloud/conda-forge/linux-64::libwebp-base-1.1.0-h516909a_3
  ninja              anaconda/cloud/conda-forge/linux-64::ninja-1.10.0-hc9558a2_0
  olefile            anaconda/cloud/conda-forge/noarch::olefile-0.46-py_0
  pillow             anaconda/cloud/conda-forge/linux-64::pillow-6.2.1-py37hd70f55b_1
  pytorch            pytorch/linux-64::pytorch-1.5.1-py3.7_cuda10.2.89_cudnn7.6.5_0
  torchvision        pytorch/linux-64::torchvision-0.6.1-py37_cu102

Proceed ([y]/n)?
and the deafult PIL is 6.2.1 version.  if the version is still low, maybe you can pip install direclty PIL 7.x version to workaround the issue. 
 
Best Regards,
Ying 
0 Kudos