Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
403 Views

Caffe NCSDK Installation Error on a Raspberry pi

Hello,

 

I bought a Neural Compute Stick 2 and I'm trying to install the NCSDK on my raspberry pi. However, the installations fails while compiling the caffe. I get an error on line 648.

 

I can install successfully the NCSDK without installing caffe, but when I tried running the mvNCCompile command I got an error that the module "caffe" could not imported. Can you help me?

 

EDIT: I commented the import lines for Caffe in the parsers of mvNCCompile and now I can get it working without it. However, I'm trying to convert a tensorflow model and what I get when running the mvNCCompile is this:

 

[Error 5] Toolkit Error: Stage Details Not Supported: Top Not Found conv1d_1/convolutions/ExpandDims
Tags (2)
0 Kudos
1 Reply
idata
Community Manager
128 Views

Hi @Mortis19

 

The error you are seeing [Error 5] Toolkit Error: Stage Details Not Supported: Top Not Found conv1d_1/convolutions/ExpandDims is related to the layer profile from caffe which is generated when caffe is downloaded and built. Could you copy/paste the error message that was prompted during the make install? Are you trying to install the ncsdk version 1 or 2?

 

Also, I undersand you are using an Intel Neural Compute Stick 2. NCS 2 is only supported on OpenVINO and will not work with the ncsdk. There was a recent OpenVINO release (R5) that provides preview support for Raspbian* 9, please checkout the release notes for more info. I have not tried to install OpenVINO on the RPi, give it a try and post any issues on the OpenVINO forum.

 

Please take a look at the getting started page for the NCS 2 to install OpenVINO.

 

https://software.intel.com/en-us/neural-compute-stick/get-started

 

I will recommend posting any issues you run into on the OpenVINO forum.

 

https://software.intel.com/en-us/forums/computer-vision

 

Regards,

 

Jesus
Reply