Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
447 Views

MAKE INSTALL ERROR!

Hi, I got the following error when I installed NCSDK:

 

-- -- CUDA is disabled. Building without it...~~ CMake Error at /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148 (message): Could NOT find CUDA: Found unsuitable version "9.2", but required is exact version "7.5" (found /usr/local/cuda) Call Stack (most recent call first): /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:386 (_FPHSA_FAILURE_MESSAGE) /usr/share/cmake-3.5/Modules/FindCUDA.cmake:949 (find_package_handle_standard_args) /usr/local/share/OpenCV/OpenCVConfig.cmake:86 (find_package) /usr/local/share/OpenCV/OpenCVConfig.cmake:105 (find_host_package) cmake/Dependencies.cmake:72 (find_package) CMakeLists.txt:43 (include) -- Configuring incomplete, errors occurred! See also "/opt/movidius/ssd-caffe/build/CMakeFiles/CMakeOutput.log". See also "/opt/movidius/ssd-caffe/build/CMakeFiles/CMakeError.log". Installation failed. Error on line 647 Makefile:47: recipe for target 'install' failed make: *** [install] Error 1

 

As the error suggest the cuda version should be exact "7.5", and I find that cuda 7.5 is not supported for Ubuntu 16.04. So how can I resolve the problem?

Tags (1)
0 Kudos
1 Reply
idata
Community Manager
166 Views

I've resolved the problem. It was a cuda version problem of OPENCV. I modified /usr/local/share/OpenCV/OpenCVConfig.cmake: set(OpenCV_CUDA_VERSION "9.2");

 

After the modifcation, the make process of NCSDK succeed.
Reply