Community
cancel
Showing results for 
Search instead for 
Did you mean: 
278 Views

OpenVINO GPU error in 2019 R2

Hi,

I am running the demo_benchmark_app sample given in the demo directory on GPU with FP16 precision. I am facing the following issue while running the demo.

[Step 7/11] Loading the model to the device
[ ERROR ] program creation failed: ..\thirdparty\clDNN\src\gpu\convolution_gpu.cpp at line: 210
An error has occurred for convolution:conv1
Best_kernel.empty()(true) should be false
Cannot find a proper kernel with these arguments

 

And then I added the -c argument (i.e. the path to custom_kernels.xml). While running the sample with this setup, I am facing the following issue.

[Step 2/11] Loading Inference Engine
[ INFO ] GPU extensions is loaded  "C:\Program Files (x86)\IntelSWTools\openvino_2019.2.242\deployment_tools\inference_engine\bin\intel64\Release"\cldnn_global_custom_kernels.xml -niter 1000
[ INFO ] InferenceEngine:
        API version ............ 2.0
        Build .................. 27579
        Description ....... API
[ INFO ] Device info:
[ ERROR ] Failed to create plugin C:\Program Files (x86)\IntelSWTools\openvino_2019.2.242\deployment_tools\inference_engine\bin\intel64\Release\clDNNPlugin.dll for device GPU
Please, check your environment
Error loading custom layer configuration file: "C:\Program, File was not found at offset 0.

 

I am unable to find the reason. Is there any modifications required in order to run the sample on GPU in OpenVINO 2019 R2. Please let me know the changes required to execute the sample.

Thank You.

0 Kudos
3 Replies
Shubha_R_Intel
Employee
278 Views

Dear Ramachandruni, Anjaneya Srujit,

Did you run setupvars.bat under bin first ?

Thanks,

Shubha

ashwinpr
Beginner
278 Views

Hi, 

I am using intel openvino in windows. In that I am trying to run benchmark_app.exe with squeezenet1.1 as model and car image as test data in GPU. But I am getting the following error:

[Step 6/11] Configuring input of the model
[Step 7/11] Loading the model to the device
[ ERROR ] Error has occured for: pooling:pool1
Best_kernel.empty()(true) should be false
Cannot find a proper kernel with this arguments

And then I added the -c argument (i.e. the path to custom_kernels.xml). While running the sample with this setup, I am facing the following issue.

[Step 2/11] Loading Inference Engine
[ INFO ] GPU extensions is loaded  "C:\Program Files (x86)\IntelSWTools\openvino_2020.2\deployment_tools\inference_engine\bin\intel64\Release"\cldnn_global_custom_kernels.xml 
[ INFO ] InferenceEngine:
        API version ............ 2.0
        Build .................. 27579
        Description ....... API
[ INFO ] Device info:
[ ERROR ] Failed to create plugin C:\Program Files (x86)\IntelSWTools\openvino_2019.2.242\deployment_tools\inference_engine\bin\intel64\Release\clDNNPlugin.dll for device GPU
Please, check your environment
Error loading custom layer configuration file: "C:\Program, File was not found at offset 0.

Please tell the solution to solve the above problems.

 

ashwinpr
Beginner
278 Views

Hi, 

I am using intel openvino in windows. In that I am trying to run benchmark_app.exe with squeezenet1.1 as model and car image as test data in GPU. But I am getting the following error:

[Step 6/11] Configuring input of the model
[Step 7/11] Loading the model to the device
[ ERROR ] Error has occured for: pooling:pool1
Best_kernel.empty()(true) should be false
Cannot find a proper kernel with this arguments

And then I added the -c argument (i.e. the path to custom_kernels.xml). While running the sample with this setup, I am facing the following issue.

[Step 2/11] Loading Inference Engine
[ INFO ] GPU extensions is loaded  "C:\Program Files (x86)\IntelSWTools\openvino_2020.2\deployment_tools\inference_engine\bin\intel64\Release"\cldnn_global_custom_kernels.xml 
[ INFO ] InferenceEngine:
        API version ............ 2.0
        Build .................. 27579
        Description ....... API
[ INFO ] Device info:
[ ERROR ] Failed to create plugin C:\Program Files (x86)\IntelSWTools\openvino_2019.2.242\deployment_tools\inference_engine\bin\intel64\Release\clDNNPlugin.dll for device GPU
Please, check your environment
Error loading custom layer configuration file: "C:\Program, File was not found at offset 0.

Please tell the solution to solve the above problems.

 

Reply