Intel® Distribution of OpenVINO™ Toolkit
Community assistance about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all aspects of computer vision-related on Intel® platforms.
6411 Discussions

Problem loading tensorflow ssd model for openvino on a raspberry



I want to run the ssd_mobilenet from tensorflow models api on a raspberry with movidius using openvino but I have problems loading the IR file.


I installed the lastest version of openvino on my pc (ubuntu 16) following this guide

then I used the model optimizer to create the IR file and tested it no problem.


then I installed openvino for raspbian following this guide

but, while running the sample I got an error

RuntimeError: Check 'axis < static_cast<size_t>(input_rank)' failed at /teamcity/work/scoring_engine_build/releases_2020_1/ngraph/src/ngraph/op/gather.cpp:140:

While validating node 'Gather[Gather_1718](patternLabel_1714: float{10,20,30}, patternLabel_1715: int64_t{5}, patternLabel_1717: int64_t{1}) -> (??)':

The axis must => 0 and <= input_rank (axis: 4294967295)


and I found that this guy had the same problem

using the model form 2019 to run the sample worked perfectly but I still get the error when I try to use my bin and xml

0 Kudos
1 Reply

Hi FSern,


Thanks for reaching out.

As you can check on the thread you referred to, this is an issue with the latest OpenVINO™ toolkit version (2020.1). The "axis" error is caused by the new IR v10 format.

Could you please generate the model with the following parameter and tell us if it works: 



If it does not work, we recommend you installing the previous version of OpenVINO™ toolkit (2019 R3.1) on your Ubuntu 16 system, convert the model there, which will generate the IR v7 format and that should work successfully with the Intel® Neural Compute Stick 2 on the raspberry pi.


Please, as this post is a duplicate from this thread, reply to us on that forum and we will continue to give you assistance there.


Best Regards,

David C.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos