Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
370 Views

Tiny YOLO, error loading graph on RaspberryPi

Hello friends,

 

I just wanted to add a custom class for testing.

 

I've train the model on windows using Darkflow and is working relatively fine, I'm able to test locally for unseen images, video and usb camera.

 

Now from DarkFlow, I exported PB like this

 

flow --model cfg/train.cfg --load -xxx --savepb where xxx is desired checkpoint

 

I have installed NCSDK (v1) into VBOX and appears to working fine, except some examples that are not built because USB toggling.

 

I tried to convert PB to GRAPH like this:

 

mvNCCompile ./tiny-yolo-voc-test.pb -s12 -o ./tiny-yolo-voc-test.graph

 

Initially, errors, but after upgrade TENSORFLOW to the same version as in DARFLOW (1.13.1) it worked.

 

Now trying with that GRAPH on Raspberry, error

 

Error - could not load tiny yolo graph file: /opt/movidius/graphs/tiny_yolo/tiny-yolo-voc-test.graph

 

Traceback (most recent call last):

 

File "/opt/test/demo-tool/run.py", line 420, in

 

sys.exit(main())

 

File "/opt/test/demo-tool/run.py", line 325, in main

 

QUEUE_WAIT_MAX, QUEUE_WAIT_MAX)

 

File "/opt/test/demo-tool/tiny_yolo_processor.py", line 46, in init

 

self._fifo_in, self._fifo_out = self._ty_graph.allocate_with_fifos(ncs_device, blob)

 

File "/usr/local/lib/python3.5/dist-packages/mvnc/mvncapi.py", line 615, in allocate_with_fifos

 

raise Exception(Status(status))

 

Exception: Status.UNSUPPORTED_GRAPH_FILE

 

root@me:/home/pi/Desktop#

 

Any idea?

Tags (2)
0 Kudos
1 Reply
Highlighted
Community Manager
25 Views

Hi @rianovich96

 

Your graph file is likely corrupt since you're using a previous version of the NCSDK. Reinstall the latest version of the NCSDK here. And then try to recompile the graph file.

 

Let me know if this was helpful

 

Best Regards,

 

Sahira
0 Kudos