Intel® Distribution of OpenVINO™ Toolkit
Community support and discussions about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all things computer vision-related on Intel® platforms.
5774 Discussions

make: execvp: ./ Text file busy

Community Manager

I'm trying to build ncsdk with docker per the official instructions:


When I run: docker build -t ncsdk -f ./extras/docker/Dockerfile


I get: make: execvp: ./ Text file busy


Full output:


$ docker build -t ncsdk -f ./extras/docker/Dockerfile


Sending build context to Docker daemon 156 MB


Step 1/5 : FROM ubuntu:16.04


---> e13f3d529b1a


Step 2/5 : RUN apt-get update && apt-get install -y build-essential sed sudo tar udev wget && apt-get clean


---> Using cache


---> fdb8fb24da8a


Step 3/5 : COPY ./ ncsdk/


---> 0571e1c68c0f


Removing intermediate container f709f2d4d324


Step 4/5 : WORKDIR "/ncsdk"


---> b578d2146cec


Removing intermediate container 79d963e4cf6d


Step 5/5 : RUN make install


---> Running in 19a226ff30c7




make: execvp: ./ Text file busy


Makefile:27: recipe for target 'uninstallopencv' failed


make: *** [uninstallopencv] Error 127


The command '/bin/sh -c make install' returned a non-zero code: 2


Yet, when I go into the docker container with docker run -it a3ab6a2231f8 /bin/bash and run ./, it succeeds:


root@3ddf9f7bec3d:/ncsdk# ./


OpenCV uninstall starting


Reading installer configuration variables from ./ncsdk.conf


OpenCV uninstall finished


What could be the problem?




The official instructions say to use docker-ce, but I'm using docker 1.13.1
0 Kudos
1 Reply
Community Manager

Solved: use docker-ce.