Community
cancel
Showing results for 
Search instead for 
Did you mean: 
jain__Yasha
Beginner
181 Views

openvino samples building error

error: ‘const class InferenceEngine::Core’ has no member named ‘ReadNetwork’; did you mean ‘LoadNetwork’?
         auto network = ie.ReadNetwork(FLAGS_m_reid);

 


I get this error wen building the openvino samples for raspberrypi. 

                       ^~~~~~~~~~~
/home/pi/openvino/deployment_tools/inference_engine/include/ie_core.hpp:58:23: note:   candidate expects 3 arguments, 1 provided
/home/pi/Downloads/open_model_zoo-master/demos/crossroad_camera_demo/main.cpp: In member function ‘virtual InferenceEngine::CNNNetwork PersonAttribsDetection::read(const InferenceEngine::Core&)’:
/home/pi/Downloads/open_model_zoo-master/demos/crossroad_camera_demo/main.cpp:342:27: error: ‘const class InferenceEngine::Core’ has no member named ‘ReadNetwork’; did you mean ‘LoadNetwork’?
         auto network = ie.ReadNetwork(FLAGS_m_pa);
                           ^~~~~~~~~~~
                           LoadNetwork
/home/pi/Downloads/open_model_zoo-master/demos/crossroad_camera_demo/main.cpp: In member function ‘virtual InferenceEngine::CNNNetwork PersonReIdentification::read(const InferenceEngine::Core&)’:
/home/pi/Downloads/open_model_zoo-master/demos/crossroad_camera_demo/main.cpp:443:27: error: ‘const class InferenceEngine::Core’ has no member named ‘ReadNetwork’; did you mean ‘LoadNetwork’?
         auto network = ie.ReadNetwork(FLAGS_m_reid);
                           ^~~~~~~~~~~
   

0 Kudos
2 Replies
jain__Yasha
Beginner
181 Views

I tried to instal the samples projects

Max_L_Intel
Moderator
181 Views

Hello Yasha.

Please let me know do you use the latest OpenVINO toolkit 2020.1 build for Raspberry Pi from here? https://download.01.org/opencv/2020/openvinotoolkit/

Do you try to build these demos with ./build_demos.sh script within open_model_zoo-master/demos folder? If so, try also build them with the following command from the same folder

cmake --build ./

Actually, we've seen this error before on systems with 2020.1 build where some other previous build (e.g. 2019 R3) was installed before. So if the suggestion above doesn't help, please also have a chance to remove all the OpenVINO toolkit components from your Raspbian OS and then try a fresh installation.

Best regards, Max.

Reply