Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
140 Views

sudo ./install_prerequisites.sh Error (Mac OSX 10.15.5)

Jump to solution

I tried to follow the installation instruction here, and I got this error when it tries to install Tensorflow? Any ideas?

 

raylo@Raymonds-MacBook-Pro openvino % cd /opt/intel/openvino/deployment_tools/model_optimizer/install_prerequisites

 

raylo@Raymonds-MacBook-Pro install_prerequisites % sudo ./install_prerequisites.sh

 

Password:

WARNING: The directory '/Users/raylo/Library/Caches/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.

WARNING: The directory '/Users/raylo/Library/Caches/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.

Collecting tensorflow>=1.2.0 (from -r /opt/intel/openvino_2020.4.287/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 1))

  Downloading https://files.pythonhosted.org/packages/fb/59/1446c28d5dec00609ab664217acdbd37cf93704ae37233c1392465... (165.2MB)

     |████████████████████████████████| 165.2MB 422kB/s

Collecting mxnet<=1.5.1,>=1.0.0 (from -r /opt/intel/openvino_2020.4.287/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 2))

  ERROR: Could not find a version that satisfies the requirement mxnet<=1.5.1,>=1.0.0 (from -r /opt/intel/openvino_2020.4.287/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 2)) (from versions: 1.6.0, 1.7.0.post1)

ERROR: No matching distribution found for mxnet<=1.5.1,>=1.0.0 (from -r /opt/intel/openvino_2020.4.287/deployment_tools/model_optimizer/install_prerequisites/../requirements.txt (line 2))

WARNING: You are using pip version 19.2.3, however version 20.2.3 is available.

You should consider upgrading via the 'pip install --upgrade pip' command.

0 Kudos

Accepted Solutions
Highlighted
Moderator
119 Views

Hi Raymond,

I've just validated our installation steps for OpenVINO 2020.4 on MacOS Catalina 10.15.5, and they are perfectly fine. We suspect that the error you're facing is due to incompatible Python version with OpenVINO. As such please ensure that your Python version is Python 3.5 - 3.7 only.


The software requirements for Intel Distribution of OpenVINO™ toolkit for macOS are given in the following page:

https://docs.openvinotoolkit.org/2020.4/openvino_docs_install_guides_installing_openvino_macos.html#...


Regards,

Munesh



View solution in original post

0 Kudos
5 Replies
Highlighted
New Contributor I
138 Views

I actually commented out the mxnet and it works. I think the Tensorflow 2.3 is not compatible with the rest.

ERROR: tensorflow 2.3.0 has requirement numpy<1.19.0,>=1.16.0, but you'll have numpy 1.19.2 which is incompatible.

0 Kudos
Highlighted
New Contributor I
136 Views

And if i take out the upper bounce limitation, it installs but does that mean OpenVINO will fail? 

mxnet>=1.0.0

0 Kudos
Highlighted
Moderator
120 Views

Hi Raymond,

I've just validated our installation steps for OpenVINO 2020.4 on MacOS Catalina 10.15.5, and they are perfectly fine. We suspect that the error you're facing is due to incompatible Python version with OpenVINO. As such please ensure that your Python version is Python 3.5 - 3.7 only.


The software requirements for Intel Distribution of OpenVINO™ toolkit for macOS are given in the following page:

https://docs.openvinotoolkit.org/2020.4/openvino_docs_install_guides_installing_openvino_macos.html#...


Regards,

Munesh



View solution in original post

0 Kudos
Highlighted
New Contributor I
112 Views

I can confirm that 3.8 did break many of these dependencies. I would suggest adding a version upper bound for tensorflow as it seems to be the one breaking the rest of the installation.


I've switched down to 3.7 manually using brew on mac. It seems the 3.8 from the default xcode installation is breaking everything (and somehow the installation automatically picked and installed these on the first time installation of the openvino tool kit).

 

-ray

0 Kudos
Highlighted
Moderator
94 Views

Hi Raymond,

We have highlighted your concerns to the OpenVINO development team. This thread will no longer be monitored since this issue has been resolved. If you need any additional information from Intel, please submit a new question.

 

Regards,

Munesh