Intel® Edge Software Hub
Get help on building Edge Software Hub solutions for edge compute node
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
300 Discussions

ESDQ 5.0 on ElKhart Lake Platform

Funway
Beginner
2,568 Views

Dear Sirs

We run ESDQ 5.0 on Elkhart lake platform and there are many failed items . Could you have some suggestions for failed  items ? 

 

Best Regards

Funway

Labels (1)
0 Kudos
1 Solution
Xiang_Intel
Moderator
1,576 Views

Hi Funway,

 

Just a piece of follow-up information, you can enable the HEVC VDEnc on your platform by following the steps below.

Media sdk sample encode test failed with the message: 

“ERROR], sts=MFX_ERR_UNSUPPORTED(-3),…"  

Follow the steps below as a possible solution: 

sudo apt install --reinstall linux-firmware 
Add i915.enable_guc=2  in /etc/default/grub: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.force_probe=* i915.enable_guc=2" 
sudo update-initramfs –u 
sudo update-grub 
Reboot the system.
After reboot, execute the command:  dmesg | grep guc
Verify the logs for guc information. If output doesn't contain guc details, then get the latest guc/huc firmware. Copy the firmware to /lib/firmware/i915/, and reboot the system.

This will help to enable the HEVC VDEnc on your platform and rerun the test again. The “mediasdk_sample_encode_with_h265” test case should be able to run successfully.

Do let me know if there is still issue after you run these changes and do help me to accept as solution if this help to fix the issue.

 

Xiang Yang

View solution in original post

23 Replies
JesusE_Intel
Moderator
145 Views

Hi Funway,


Looking at the latest test report all tests passed. I noticed you have Kernel 5.4.143-asrock-custom-mr2-v0.2 installed and in the test report from 2021-11-16 you had kernel 5.11.0-40-generic. Please confirm if changing the kernel and enabling HEVC VDEnc as Xiang Yang suggested resolved your issue.


Regards,

Jesus


JesusE_Intel
Moderator
96 Views

Hi Funway,

 

Please let me know if you have any additional questions or if we can proceed to close this discussion. 

 

Regards,

Jesus

JesusE_Intel
Moderator
94 Views

If you need any additional information, please submit a new question as this thread will no longer be monitored.


Reply