Intel® Edge Software Hub
Get help on building Edge Software Hub solutions for edge compute node
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
275 Discussions

ESDQ 6.0 Vision test module fail

TChio
Novice
256 Views

Hi Sir:

we hope to validate TGL-UP3 with Vision ESDQ .

So far we test mix ESDQ 5.0 and 6.0 componet module but still fail and many times .

 

1. what the new 6.0 Vision module can't download ?

<project path="installation/src" id="621692878bad76002bce2ee8" version="2021.4.1" label="esdq/Vision_Test_Module"/>

Downloading component esdq/Vision_Test_Module
Failed to download the module esdq/Vision_Test_Module. 404 Not Found

2.So we used old vision test module

<project id="6216928e8bad76002bce2ef4" label="esdq/Vision_Test_Module" path="installation/src" version="2021.4.1" />

for the testing with HDDL problem i had been Add following entry in $HDDL_INSTALL_DIR/config/hddl_service.config like this:
"service_settings":
{
"autoboot_boot_timeout_sec": 10,
...
}

that still fail .

+--------------------+----------+--------------------------+
| Test Module | Version | ID |
+--------------------+----------+--------------------------+
| Vision_Test_Module | 2021.4.1 | 6216928e8bad76002bce2ef4 |
| VATS_Test_Module | 2021.4 | 60f084f3acbb0a002bcaee71 |
+--------------------+----------+--------------------------+

----Starting HDDL Daemon-------
PID of HDDL Daemon - 2698435
----------------------------------------------------------------------------
Stopping the existing OpenVINO containers
----------------------------------------------------------------------------
[09:41:01.3401][2698443]I[FileHelper.cpp:268] Set file:/var/tmp/hddl_autoboot_alive.mutex owner: user-'no_change', group-'users', mode-'0660'
[09:41:01.3401][2698443]I[FileHelper.cpp:268] Set file:/var/tmp/hddl_autoboot_ready.mutex owner: user-'no_change', group-'users', mode-'0660'
[09:41:01.3401][2698443]I[FileHelper.cpp:268] Set file:/var/tmp/hddl_autoboot_start_exit.mutex owner: user-'no_change', group-'users', mode-'0660'
[09:41:01.3402][2698443]I[FileHelper.cpp:268] Set file:/tmp/hddl_autoboot_device.map owner: user-'no_change', group-'users', mode-'0660'
[09:41:01.3406][2698443]I[AutoBoot.cpp:308] [Firmware Config] deviceName=default deviceNum=0 firmwarePath=/opt/intel/openvino_2021/deployment_tools/inference_engine/external/hddl/lib/mvnc/usb-ma2x8x.mvcmd
[E:] [BSL] No device found
[09:41:01.3506][2698443]ERROR[AutoBoot.cpp:478] Error: HDDL hardware initialization failed, exits now.
Running the Container
No image found. Aborting installation.(B
[09:41:01.3287][2698435]I[main.cpp:246] ## HDDL_INSTALL_DIR: /opt/intel/openvino_2021/deployment_tools/inference_engine/external/hddl
[09:41:01.3287][2698435]I[main.cpp:248] Config file '/opt/intel/openvino_2021/deployment_tools/inference_engine/external/hddl/config/hddl_service.config' has been loaded
[09:41:01.3289][2698435]I[FileHelper.cpp:268] Set file:/var/tmp/hddl_service_alive.mutex owner: user-'no_change', group-'users', mode-'0660'
[09:41:01.3291][2698435]I[FileHelper.cpp:268] Set file:/var/tmp/hddl_service_ready.mutex owner: user-'no_change', group-'users', mode-'0660'
[09:41:01.3291][2698435]I[FileHelper.cpp:268] Set file:/var/tmp/hddl_service_failed.mutex owner: user-'no_change', group-'users', mode-'0660'
[09:41:01.3291][2698435]I[FileHelper.cpp:268] Set file:/var/tmp/hddl_start_exit.mutex owner: user-'no_change', group-'users', mode-'0660'
[09:41:01.3300][2698435]I[AutobootStarter.cpp:156] Info: No running autoboot process. Start autoboot daemon...
[09:41:02.3312][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 1 seconds ...
[09:41:03.3323][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 2 seconds ...
[09:41:04.3331][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 3 seconds ...
[09:41:05.3345][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 4 seconds ...
[09:41:06.3359][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 5 seconds ...
[09:41:07.3370][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 6 seconds ...
[09:41:08.3386][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 7 seconds ...
[09:41:09.3399][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 8 seconds ...
[09:41:10.3412][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 9 seconds ...
[09:41:11.3425][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 10 seconds ...
[09:41:12.3439][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 11 seconds ...
[09:41:13.3449][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 12 seconds ...
[09:41:14.3463][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 13 seconds ...
[09:41:15.3476][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 14 seconds ...
[09:41:16.3486][2698435]I[AutobootStarter.cpp:79] Info: Service has been waiting for Autoboot to boot up for 15 seconds ...
[09:41:16.3486][2698435]ERROR[AutobootStarter.cpp:89] Error: Service wait Autoboot to get ready failed due to timeout after 15 seconds.
[09:41:16.3487][2698435]W[AutobootStarter.cpp:90]
** Suggestion: The timeout by default is 10 seconds, and you can increase it by following steps:
(1) Add following entry in $HDDL_INSTALL_DIR/config/hddl_service.config like this:
"service_settings":
{
"autoboot_boot_timeout_sec": 10,
...
}
(2) Change the '10' to a larger value to increase the time out window, then try again.

[09:41:16.3487][2698435]ERROR[AutobootStarter.cpp:49] Error: Failed to start autoboot
[09:41:17.6488][2698435]ERROR[main.cpp:77] Error: Start Service failed due to autoboot failure

0 Kudos
5 Replies
SShan_Intel
Employee
241 Views

Hi TChio,

 

May i know have you try install the latest 6.1 ? I have tested and it manage to install esdq/Vision_Test_Module. Also, may I know if you are installing within corporate network? Lastly, what is your ubuntu kernel version ?

 

Regards,

SShan_Intel

 

 

TChio
Novice
237 Views

Hi SShan :

1. That version 6.1 not 6.0 . (Vision_Test_Module download fial , error 404) ; because i confuse that LicenseSummary-ESDQ-6.0 .

2. we used smart phone share Ethernet by USB .

3. System information as below . ( 5.8 and 5.13 had been test)

System Category Property Value
0 SOFTWARE INFO OS version Ubuntu 20.04.4 LTS
1 SOFTWARE INFO Kernel

5.13.0-41-generic

 

 

Regards

Tab Chiou

SShan_Intel
Employee
167 Views

Hi Tab Chiou,

 

Could you sent me log file ?

/var/log/esb-cli/Edge_Software_Device_Qualification_6.1/output.log

/var/log/esb-cli/Edge_Software_Device_Qualification_6.1/esdq/install.log

 

Also for you information, this error that you getting "[E:] [BSL] No device found
[09:41:01.3506][2698443]ERROR[AutoBoot.cpp:478] Error: HDDL hardware initialization failed, exits now." means that you havent setup HDDL device in your system.

 

Regards,

SShan_Intel

TChio
Novice
161 Views

Hi SShan :

as attached for you .

we already use below way hope to skip HDDL but no used. 

./esdq run [MODULE_ID]

 

 

Regards

Tab Chiou 

SShan_Intel
Employee
113 Views

Hi TChio,

 

Sorry for late response, we have fix the issue. Could you redownload the package and try it again? 

https://software.intel.com/iot/edgesoftwarehub/download/home/esdq_vision

 

Regards,

SShan_Intel

Reply