Community
cancel
Showing results for 
Search instead for 
Did you mean: 
jruggieri
Beginner
162 Views

Error when try to run provision command

Hi! I just installed EIS Framework and when trying to follow these steps I am getting an error.

STEPS
1) On a Console Terminal, go to "edge_insights_industrial>Edge_Insights_for_Industrial_X.X.X>IEdgeInsights>build":- Run the builder: python3 eis_builder.py
2) Provision new configuration:
cd provision/
sudo systemctl restart docker.service
sudo ./provision_eis.sh ../docker-compose.yml 
 
After that I'm getting this:
 
[Warning] One or more build-args [EIS_UID] were not consumed
Successfully built 3005ae73e4b9
Successfully tagged ia_etcd_provision:2.3
Creating ia_etcd ... error

ERROR: for ia_etcd Cannot create container for service ia_etcd: failed to mount local volume: mount /opt/intel/eis/data/etcd/:/var/snap/docker/common/var-lib-docker/volumes/edgeinsightssoftware_vol_etcd/_data, flags: 0x1000: no such file or directory

ERROR: for ia_etcd Cannot create container for service ia_etcd: failed to mount local volume: mount /opt/intel/eis/data/etcd/:/var/snap/docker/common/var-lib-docker/volumes/edgeinsightssoftware_vol_etcd/_data, flags: 0x1000: no such file or directory
ERROR: Encountered errors while bringing up the project.
 
 
Does anyone knows what is happening and how can I resolve it? 
I already reboot the machine several times but is still failing.
 
Thanks in advance!
Best Regards!
0 Kudos
4 Replies
Murni_J_Intel
Moderator
142 Views

Hi

May I know in this case you are using the video analytics or time-series use case?

may I know if you are successfully builing EII on the first build? it will be great if you can provide me logs of your ./edgesoftware list to see if the component is being sucessfully installed

 

jruggieri
Beginner
136 Views

Hi!

I'm using a custom package (version 2.3.4) with only the essential things. 

EII is installed ok as you can see in the screenshot attached.

 

 

Murni_J_Intel
Moderator
94 Views

Hi, 

Can you help to give me some understanding of what is the step that currently you are trying to do? EII already being installed successfully and why you are trying to run the provisioning step again? Can you list to me the folder contain inside the IEdgeInsights directory?

jruggieri
Beginner
12 Views

Hi!... I re-install Ubuntu in my laptop and that did the trick.

This can be closed.

Thanks!