Intel® Edge Software Hub
Get answers from community peers to your questions about building Edge Software Hub solutions for edge compute node.
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
420 Discussions

Ingestion Doesnt auto reconnect when stream is broken

kranthi_volteo
1,407 Views

We are seeing some issues with ingestion not able to reconnect when stream is broken/down temporarily. Everything works if I restart container manually. 

 

"/VideoIngestion/config": {
    "encoding": {
      "type": "jpeg",
      "level": 95
    },
    "ingestor": {
      "type": "opencv",
      "pipeline": "rtsp://localhost:8554/live.sdp"
    }
  }

 

Also tried with different ingestor - gstreamer. 

 

Labels (1)
0 Kudos
5 Replies
WengWai_C_Intel
Moderator
1,388 Views

Hi @kranthi_volteo ,

Can you provide more info regarding the scenario you are having on your setup? 

1) How the stream is broken? RTSP camera disconnected (turnoff)?

2) Or the camera still up running but it doesn't have the stream running?

3) Roughly how long the duration for the stream disconnected before it resume? 

Meantime, when you run with opencv ingestor, can you add the "loop_video=true" into the VIdeoIngestion config through the ETCD webUI (example as below) and try with you scenario?

WengWai_C_Intel_0-1602068599781.png

 

 

0 Kudos
kranthi_volteo
1,375 Views

Hi Weng,

     I am currently using virtual RTSP stream. May be just couple of seconds when  stream disconnected, as I can see in VLC stream works perfectly fine. 

0 Kudos
WengWai_C_Intel
Moderator
1,362 Views

Hi @kranthi_volteo ,

Did you try add the loop_video setting with opencv ingestor per suggestion earlier? Please let us know, thanks!

0 Kudos
kranthi_volteo
1,353 Views

Hi Weng, 

     No, I can try but, we are not using file to loop, we are directly using rtsp stream URL in our pipeline.

0 Kudos
WengWai_C_Intel
Moderator
1,344 Views

Hi @kranthi_volteo ,

The loop_video for opencv will trigger retry if the stream disconnected. Therefore, suggest you to try with this config to check on the scenario you are seeing. Please let us know once you have a chance to try it.'

thanks!

0 Kudos
Reply