Intel® Edge Software Hub
Get help on building Edge Software Hub solutions for edge compute node
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
263 Discussions

Intelligent Traffic Management Grafana container not running

YY4
Employee
850 Views

when following the steps at:

https://software.intel.com/content/www/us/en/develop/articles/intelligent-traffic-management.html

to run the demo, i can see that grafana actually not running with a error message when checking the log:

itm_smartcity | 2021-08-15 :: Connecting grafana: Grafana container not up yet, retrying...

 

seems the grafana container never started, i try to restart it manually buy failed...  

 

attached the log

Labels (1)
0 Kudos
1 Solution
Xiang_Intel
Moderator
754 Views
7 Replies
Murni_J_Intel
Moderator
825 Views

Hi @YY4 

 

Can you please share your $ docker ps and $ docker logs -f itm_smarticty output?

please ensure to run the below to set the host IP before you run the $ docker-compose up -d command 

export HOST_IP=$(hostname -I | cut -d' ' -f1)

 

YY4
Employee
812 Views

please see attached log, thanks so much!

YY4
Employee
790 Views

refreshed the whole SW but still not be able to bring up.

Xiang_Intel
Moderator
761 Views

Hi @YY4 ,

 

I am able to reproduce your issue stated above. It is found that when the HOST_IP env variable is set not correctly, then will see this issue.

Based on the log you have provided, the host ip is set to 172.17.0.1.

Can I request your help to verify again?

Steps:

1. In a new terminal, go to Intelligent_Traffic_Management_<version>/Intelligent_Traffic_Management/intelligent-traffic-management

2. export your current machine IP address. (You can look up your system IP address via ip a or ifconfig).

    export HOST_IP=<System-IP-address>

3. Verify that HOST_IP is correctly sourced into the environment.

     export | grep HOST_IP

4. Then run docker-compose up.

     sudo -E docker-compose up

     

YY4
Employee
756 Views

sorry not updated the latest status in time, i have fixed the issue, really appreciate for the supports. 

Xiang_Intel
Moderator
755 Views

Great to hear this from you. 

JesusE_Intel
Moderator
723 Views

If you need any additional information, please submit a new question as this thread will no longer be monitored.

Reply