Intel® Edge Software Hub
Get answers from community peers to your questions about building Edge Software Hub solutions for edge compute node.
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
378 Discussions

Issue with running Automated_checkout reference implementation



I downloaded Automated_checkout and tried to install in my desktop machine (Ubuntu 18.04.4 LTS) with the command (./edgesoftware install), installation was successfull

Installation of package complete
|            Id            |            Module           |  Status |
| 5f21392e9e63c9002a6fd88d | Docker Community Edition CE | SUCCESS |
| 5f213aae9e63c9002a6fd88e |        Docker Compose       | SUCCESS |
| 5f2291ba4fc424002ac3031d |      Automated Checkout     | SUCCESS |

But when i run the Refernce implemnetation using "make run", i get the below error, could not start redis server.

Creating edgex-core-consul ... done
ng userland proxy: listen tcp bind: address already in use

ERROR: for redis  Cannot start service redis: driver failed programming external connectivity on endpoint edgex-redis (038970d25954f38ec033e7431fb70a10521f56a505f29669db147a9eccea66df): Error starting userland proxy: listen tcp bind: address already in use
ERROR: Encountered errors while bringing up the project.
Makefile:41: recipe for target 'run' failed
make: *** [run] Error 1

0 Kudos
1 Reply


  1. Automated Checkout deploys its own instance of EdgeX. If you already have EdgeX installed and running on your system, please disable EdgeX when running Automated Checkout.
  2. Ensure you donot have running Automated checkout receipe in parallel.
    1. make down && make clean-docker
    2. docker rm -f $(docker ps -aq)
  3. Ensure you don’t have any existing containers or processes running on the same port as any of the ports that are mapped in docker-compose.yml. You can debug this with both commands, changing 6379 for your port in question:
    1. docker ps | grep -i 6379
    2. sudo netstat -plunt | grep -i 6379
  4. If you have no processes or containers running that conflict with ports, and there is still a failure to run the ESH Automated Checkout recipe, then it’s possible that the Docker service needs to be restarted and stop the redis-server
    1. sudo systemctl restart docker.service
    2. sudo /etc/init.d/redis-server stop
  5. if you have issue with MQTT Broker-"ERROR: for mqtt-broker  Cannot start service mqtt-broker:" Ensure you stopped mosquitto services
    1. sudo systemctl stop mosquitto
  6. Try again ruuning "make run" should be success.
0 Kudos