Intel® Edge Software Hub
Get answers from community peers to your questions about building Edge Software Hub solutions for edge compute node.
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
414 Discussions

Link error about EII ALPR S3 buket and EC2 ThingsBoard

jacky0327
New Contributor I
1,042 Views

Hi Intel,
I am currently experimenting with EII ALPR,
https://www.intel.com/content/www/us/en/developer/articles/reference-implementation/automated-license-plate-recognition.html


I successfully set up this case on my computer with Ubuntu 20.04 operating system, but when I connected it with AWS EC2, I encountered the following problems,


When I enter the following command to build the webui,

sudo make webui EII_BASE=/home/gvsai/automated_license_plate_recognition/Automated_License_Plate_Recognition_2022.1/IEdgeInsights REPO_FOLDER=/home/gvsai/automated_license_plate_recognition/Automated_License_Plate_Recognition_2022.1/Automated_License_Plate_Recognition/EII-LicensePlateRecognition-UseCase

Immediately the following warning appears:
2022-11-30 16:02:10,291 : WARNING : root : [cloud_manager.py] : in line [51] : Empty keys (aws).
2022-11-30 16:02:10,291 : WARNING : root : [cloud_manager.py] : in line [65] : Wrong credentials: waiting for valid aws credentials.


gnome-shell-screenshot-3RYKW1.png

When I enter the correct access key and the correct s3 bucket on the webui, the error message will appear as shown below,
After I set up ThingsBoard Cloud Data on AWS EC2, when I input the correct access token key on the webui, the error message as shown below,
gnome-shell-screenshot-HDSNV1.png

 

What is the reason for this problem?

Labels (1)
0 Kudos
1 Solution
JesusE_Intel
Moderator
744 Views

Hi jacky0327,


I have an update from the development team. The current release only works for aws instances that create in region us-east-1. Could you try to create an AWS instance in this region? This issue should be addressed in the next release. At this time, I don't have an ETA on the next release.


Regards,

Jesus


View solution in original post

0 Kudos
6 Replies
JesusE_Intel
Moderator
1,029 Views

Hi jacky0327,


Thank you for reporting, I am able to reproduce the issue after inputting my correct AWS details.

Let me reach out to the engineering team for additional assistance.


Regards,

Jesus


0 Kudos
jacky0327
New Contributor I
994 Views

Hi JesusE_Intel,

Thank you for your help, please teach me if you have any progress.
We have subscriptions to full AWS services.

Regards,
Jacky

0 Kudos
JesusE_Intel
Moderator
821 Views

Hi Jacky,


I'm really sorry about the delay from our side. I escalated this to the development team. Let me follow up with them to get the latest update.

I appreciate your patience. 


Regards,

Jesus


0 Kudos
JesusE_Intel
Moderator
745 Views

Hi jacky0327,


I have an update from the development team. The current release only works for aws instances that create in region us-east-1. Could you try to create an AWS instance in this region? This issue should be addressed in the next release. At this time, I don't have an ETA on the next release.


Regards,

Jesus


0 Kudos
jacky0327
New Contributor I
728 Views

Hi Jesus,

Hi, thank you for your help, we will come back to test after the next version update.

We previously chose to set up AWS EC2 in Oregon.

Regards
Jacky

0 Kudos
JesusE_Intel
Moderator
712 Views

Thanks Jacky! If you need any additional information, please submit a new question as this thread will no longer be monitored.


0 Kudos
Reply