Intel® Edge Software Hub
Get help on building Edge Software Hub solutions for edge compute node
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.

TLS SSL/HTTLS can't be work

Tconnell
Novice
1,045 Views

Hi Intel,

 

I follow #631070 TLS Doc rev1.2 - 1.3.1

setup SSL still can not be work

still show unsafe

 

BTW:

doc setup step seems only windows chrome, I also try ubuntu chrome

and restart browser ,  still can not be work

Labels (1)
0 Kudos
1 Solution
JesusE_Intel
Moderator
968 Views

Hi Tconnell,


From the screenshots it looks like you are following the correct steps. However, it looks like you are trying to access TLS using localhost. Instead, try accessing it using the IP address: https://<system ip>


Regards,

Jesus


View solution in original post

7 Replies
JesusE_Intel
Moderator
1,000 Views

Hi Tconnell


Did you clear your cache and restarted your browser after you installed the ca_certificate.pem under Trusted Root Certificate Authorities? On my side, TLS also showed as unsafe until I cleared my cache and restarted my browser.


Regards,

Jesus


Tconnell
Novice
979 Views

Yes, ca_certificate.pem and Trusted Root Certificate Authorities

and cleared cache and restarted my browser.

Can you help me check my step is correct?

attachment is my step(Ubuntu/Windows Chrome)

JesusE_Intel
Moderator
969 Views

Hi Tconnell,


From the screenshots it looks like you are following the correct steps. However, it looks like you are trying to access TLS using localhost. Instead, try accessing it using the IP address: https://<system ip>


Regards,

Jesus


Tconnell
Novice
949 Views

Hi Jesus,

 

Thanks you so much,

It can be work now.

External IP - work       (https://10.1.x.x

Internal IP - not work(https://127.0.0.1)

localhost - not work  (https://localhost)

Tconnell
Novice
934 Views

Hi Intel,

 

Sorry, one more question.

Does this setting can not work on TLS docker version?last reply is naive version.

I follow same step, delete old cert, import docker ssl cert, clear cache, restart web browser

and connect external ip https can not work

JesusE_Intel
Moderator
905 Views

Hi Tconnell,


It should work with TLS Docker as well. In fact, when I was testing this from my end I used setup_TLS_docker.sh when setting it up.


Regards,

Jesus


JesusE_Intel
Moderator
873 Views

If you need any additional information, please submit a new question as this thread will no longer be monitored.


Reply