Intel® Edge Software Hub
Get help on building Edge Software Hub solutions for edge compute node
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

See our new article on Fidelity-first Ray Tracing in the Heterogeneous Compute Era.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
200 Discussions

[Ubuntu 18.04][APL] Cannot install EIS 2.3.1 successfully

davidla1
Employee
244 Views

OS: Ubuntu 18.04

Platform: APL

Kernel: Reproduced on both 4.14.93-rt53 and 4.1, 5.4.0-45-generic

I run "./edgesoftware install", and it was doing fine until the waiting one hour after installed OpenVino successfully. However, it stops due to some error.
Then, I install EIS 2.3.1 by run ./edgesoftware install" again, it shows error of Failed to update apt list. Exiting installation as below log.
I run "./edgesoftware uninstall -a" and "./edgesoftware install" again, the error is same.

Can you help me out?

 

Starting the setup...
ESB CLI version: 2020.3
Target OS: Ubuntu
[sudo] password for ubuntu:
------------------SOFTWARE INFO-------------------
Operating System: Ubuntu 18.04.4 LTS
Kernel: 5.4.0-45-generic

------------------HARDWARE INFO-------------------
Hardware Architecture: x86_64
Processor: Intel(R) Atom(TM) Processor E3950 @ 1.60GHz
Memory size: 7.6G
Total disk space (GB): 57
Free disk space (GB): 37

---------------HARDWARE ACCELERATOR---------------
No hardware accelerator found
Python version: 3.6.9
Checking Internet connection
Connected to the Internet
Checking for prerequisites
E: The repository 'https://repo.mongodb.org/apt/ubuntu bionic/mongodb-org/4.0 Release' does not have a Release file.
E: The repository 'https://download.docker.com/linux/ubuntu bionic Release' does not have a Release file.
Failed to update apt list. Exiting installation.
ubuntu@EIS-TSN-1:~/EIS/edge_insights_industrial$ 

David Lai
IOTG PMCE ICE Taiwan

 

I am working to enable a demo of EIS + TSN for Taiwan customer.

Labels (1)
0 Kudos
1 Reply
Murni_J_Intel
Moderator
219 Views

Hi @davidla1 

 

can you help to try run below comamnd ?

sudo sed -i 's|docker.com/linux/debian|docker.com/linux/ubuntu|g' /etc/apt/sources.list

sudo apt update

 

after done, try to run ./edgesoftware install command again. 

Reply