Intel® Edge Software Hub
Get help on building Edge Software Hub solutions for edge compute node
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
277 Discussions

build ia_influxdbconnector has error

Don
Beginner
895 Views

I modify /docker_setup/docker-compose.yml and unmark ia_influxdbconnector, ia_data_analytics, ia_telegraf 3 service which default is marked, and I meet a error when build container(like attached picture).

please help me to solve this error, thanks!!

Labels (1)
0 Kudos
7 Replies
Murni_J_Intel
Moderator
878 Views

Hi @Don 

can you help to provide me a screenshot of your docker-compose.yml file?

Don
Beginner
867 Views

ok, thanks for your help!

Jia-Shing_W_Intel
Moderator
845 Views

Attaching the full docker-compose.yml file from Don.

Hi Don,

A couple of questions, what's the DEV_MODE setting in .env? If it's true, you are expected to comment out the secrets sectionin all services in docker-compose.yml. If it's false, you intent to run EIS in production mode, and you manually un-commented ia_influxdbconnector, did you run provision_eis.sh to generate all the necessary certificates?

Don
Beginner
820 Views

Hi , Jia-shing

I set the DEV_mode=true in .env file, Now I already delete all about secret service in docker-compose.yml, and remove all temporary container then rebuild, but still meet the same error. 

Did I loss some steps in rebuild docker-compose?

By the way, I insert a line(RUN apt-get install -y sudo) for install sudo command in Dockerfile-openvino when I meet the other error(like attach file), maybe this action cause after that error?

Jia-Shing_W_Intel
Moderator
796 Views

Hi Don,

If you only want to do time-series analytics, there isn't a need to build ia_openvido_base, and adding a line to install sudo shouldn't affect this.

I checked the line number at which your error occurred with the Dockerfile I have, and they are different. I'm guessing you use an older version than 2.2.1, am I correct? It's highly encouraged to migrate to the latest version available from https://software.intel.com/iot/edgesoftwarehub/download/home/industrialinsights

Actually, during the new installation process, you will be asked which use case you want to enable:

* Streaming
* Historical
* Time series
* Time series + Streaming

I believe this is an easier way to solve your problem.

Regards,

Jia-Shing

Don
Beginner
785 Views

Hi, Jia-shing,

Now I install EIS on Mx-Linux not ubuntu, it would effect EIS install and cause that many error?

I will try EIS 2.2.1 on ubuntu18.04 then reply new status here, thanks for your help!

Jia-Shing_W_Intel
Moderator
763 Views
I’m not familiar with Mx-Linux, and to tell you the truth, I’m not sure. One advantage of EIS is that it’s heavily containerized so it probably will work without problems. However, Ubuntu 18.04 is the version that Intel claims support and have done full validation. It’s encouraged to use it to avoid unforeseen issues. Thank you for your understanding.
Reply