Intel® Edge Software Hub
Get answers from community peers to your questions about building Edge Software Hub solutions for edge compute node.
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
395 Discussions

cannot run influxBDConnecter test.go file

Jerry4_Liu
Novice
857 Views

Hi all,

 

I have successfully installed EII software package and dcker-compose up

Jerry4_Liu_0-1650557312501.png

 

but when I use go run to run test.go file under the InfluxDBConnecter folder , they always appear the "cannot find package "configmgr/eia configmgr" in any of: /usr/lib/go-1.10/src/" and other warnings.

Jerry4_Liu_2-1650557708807.png

So I would like to ask if anyone else has the same problem or has a solution?

 

Thanks.

Regards,

-Jerry

Labels (1)
0 Kudos
1 Solution
Sahira_Intel
Moderator
790 Views

Hi,


I see the "cannot find package EIIMessageBus/eiimsgbus" error. What version of CMake do you have installed on your system? The EII/OEI message bus relies on CMake v3.11+. Follow these instructions to install the correct version of cmake:


# Remove old CMake version

sudo apt -y purge cmake

sudo apt -y autoremove


# Download CMake

wget https://cmake.org/files/v3.15/cmake-3.15.0-Linux-x86_64.sh


# Installation CMake

sudo mkdir /opt/cmake

sudo cmake-3.15.0-Linux-x86_64.sh --prefix=/opt/cmake --skip-license


# Make the command available to all users

sudo update-alternatives --install /usr/bin/cmake cmake /opt/cmake/bin/cmake 1 --force


Sincerely,

Sahira



View solution in original post

0 Kudos
3 Replies
Sahira_Intel
Moderator
824 Views

Hi Jerry,


I apologize for not responding sooner - I am looking into this issue and will get back to you shortly.


Sincerely,

Sahira


0 Kudos
Sahira_Intel
Moderator
791 Views

Hi,


I see the "cannot find package EIIMessageBus/eiimsgbus" error. What version of CMake do you have installed on your system? The EII/OEI message bus relies on CMake v3.11+. Follow these instructions to install the correct version of cmake:


# Remove old CMake version

sudo apt -y purge cmake

sudo apt -y autoremove


# Download CMake

wget https://cmake.org/files/v3.15/cmake-3.15.0-Linux-x86_64.sh


# Installation CMake

sudo mkdir /opt/cmake

sudo cmake-3.15.0-Linux-x86_64.sh --prefix=/opt/cmake --skip-license


# Make the command available to all users

sudo update-alternatives --install /usr/bin/cmake cmake /opt/cmake/bin/cmake 1 --force


Sincerely,

Sahira



0 Kudos
Jerry4_Liu
Novice
749 Views

Hi Sahira,

 

I try to use the sudo cmake-3.15.0-Linux-x86_64.sh --prefix=/opt/cmake --skip-license this command

but it still show this information sudo: cmake-3.15.0-Linux-x86_64.sh: command not found

Thanks.

Regards,

-Jerry

0 Kudos
Reply