Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
107 Views

castle lake client installation

Jump to solution

While trying to install castle lake client I am getting an error saying:- 

{"Path":"/api/v1/configuration/bootstrap-complete","Errors":[{"Code":9000,"Message":"an error occurred. check details for more info","Details":["edge-device not visible in cluster in 5 attempts"]}],"RequestID":"753f77d3","Timestamp":1604991223957}{ERR}: Put client acknowledgement Failed! Http error :(503)!

I would like to know the reason for this. I have also attached the screenshot of the error. Any help is appreciated.

0 Kudos

Accepted Solutions
Highlighted
Moderator
58 Views

Hi,

The error is related to the Client node's Weave network interfaces communication with the CSL server node. You can first reboot the Client node to reset the network interface, redownload the client-bootstrap.sh and rerun the Client nod installation again.

Thanks!

View solution in original post

0 Kudos
3 Replies
Highlighted
Moderator
84 Views

Hello @Smrithi

Thank you for posting on the Intel® communities.

Based on your question and issue description, we noticed that this is regarding Castle Lake, a component of Orchestrator (Intel® Edge Software Hub).

We have a forum for those specific products and questions so we are moving it to the Intel® Edge Software Hub Forum so it can get answered more quickly: https://community.intel.com/t5/Intel-Edge-Software-Hub/bd-p/edge-software-hub


Best regards,

Andrew G.

Intel Customer Support Technician


0 Kudos
Highlighted
Moderator
64 Views

Hi @Smrithi 

This issue due to the client node is unable to communicate with the Castle Server Node. May I know for this setup are you running behind a corporate proxy? if yes, you might need to check on the below file to ensure all the necessary IP (Castle Manager, Castle Server, Virtual IP, and Castle Client) has been added to the no proxy setting and your proxy has been configured accordingly.

 /etc/environment

HTTP_PROXY="<your_no_proxy_ip>:<port>"HTTPS_PROXY="<your_no_proxy_ip>:<port>"NO_PROXY="localhost,127.0.0.1,<System_1_IP,System_2_IP,System_3_IP,Virtual_IP"http_proxy="<your_no_proxy_ip>:<port>"https_proxy="<your_no_proxy_ip>:<port>"no_proxy="localhost,127.0.0.1,<System_1_IP,System_2_IP,System_3_IP,Virtual_IP"

 ~/.docker/config.json

{     "proxies":      {      "default":       {       "httpProxy": "<your_no_proxy_ip>:<port>"             "httpsProxy": "<your_no_proxy_ip>:<port>"       "noProxy": "localhost,127.0.0.1,<System_1_IP,System_2_IP,System_3_IP,Virtual_IP>"       }      }    }

/etc/systemd/system/docker.service.d/http-proxy.conf

[Service]Environment="HTTP_PROXY=<your_no_proxy_ip>:<port>"Environment="NO_PROXY=localhost,127.0.0.1,<System_1_IP,System_2_IP,System_3_IP,Virtual_IP>"

 /etc/systemd/system/docker.service.d/https-proxy.conf

[Service]Environment="HTTPS_PROXY=http://<your_proxy>:<port>/"Environment="NO_PROXY=localhost,127.0.0.1,<System_1_IP,System_2_IP,System_3_IP,Virtual_IP>"

May I know if the node is being registered in your Castle Server? You can check this by using the Castle Manager UI and select in the client node tab, the registered client node will be listed. If yes, you can try to use the uninstaller_client.sh script at /opt/csl/csl-node/ directory before trying to re-install again.

Do let me know if this works on your end.

0 Kudos
Highlighted
Moderator
59 Views

Hi,

The error is related to the Client node's Weave network interfaces communication with the CSL server node. You can first reboot the Client node to reset the network interface, redownload the client-bootstrap.sh and rerun the Client nod installation again.

Thanks!

View solution in original post

0 Kudos