Intel® Edge Software Hub
Get help on building Edge Software Hub solutions for edge compute node
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.
288 Discussions

error when doing pip install of edgesoftware

vibhu-upsqrd
Beginner
586 Views

OS ubuntu 20.04 LTS

Device - up squared

 

When running python3 -m pip install edgesoftware --user i get error message

1. it assumes pip3 is installled

2. launchpadlib 1.10.13 requires testresources, which is not installed.

3. still doesnt run edgesoftware ----  edgesoftware: command not found

 

resolution

1. sudo apt-get install python3-pio

2.  sudo apt install python3-testresources

 

 

 

full log ----

python3 -m pip install edgesoftware --user
Collecting edgesoftware
Downloading edgesoftware-1.0.0-cp38-cp38-manylinux1_x86_64.whl (555 kB)
|████████████████████████████████| 555 kB 3.7 MB/s
Collecting ruamel.yaml
Downloading ruamel.yaml-0.17.16-py3-none-any.whl (109 kB)
|████████████████████████████████| 109 kB 19.8 MB/s
Collecting scp
Downloading scp-0.14.1-py2.py3-none-any.whl (8.4 kB)
Collecting wget
Downloading wget-3.2.zip (10 kB)
Collecting PyYAML>=5.4.1
Downloading PyYAML-6.0-cp38-cp38-manylinux_2_5_x86_64.manylinux1_x86_64.manylinux_2_12_x86_64.manylinux2010_x86_64.whl (701 kB)
|████████████████████████████████| 701 kB 7.6 MB/s
Requirement already satisfied: colorama in /usr/lib/python3/dist-packages (from edgesoftware) (0.4.3)
Collecting defusedxml
Downloading defusedxml-0.7.1-py2.py3-none-any.whl (25 kB)
Requirement already satisfied: paramiko in /usr/lib/python3/dist-packages (from edgesoftware) (2.6.0)
Requirement already satisfied: pexpect in /usr/lib/python3/dist-packages (from edgesoftware) (4.6.0)
Requirement already satisfied: requests in /usr/lib/python3/dist-packages (from edgesoftware) (2.22.0)
Collecting docker
Downloading docker-5.0.3-py2.py3-none-any.whl (146 kB)
|████████████████████████████████| 146 kB 9.5 MB/s
Collecting kubernetes
Downloading kubernetes-19.15.0-py2.py3-none-any.whl (1.7 MB)
|████████████████████████████████| 1.7 MB 15.4 MB/s
Collecting oyaml
Downloading oyaml-1.0-py2.py3-none-any.whl (3.0 kB)
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from edgesoftware) (1.14.0)
Collecting py-cpuinfo
Downloading py-cpuinfo-8.0.0.tar.gz (99 kB)
|████████████████████████████████| 99 kB 1.2 MB/s
Collecting termcolor
Downloading termcolor-1.1.0.tar.gz (3.9 kB)
Collecting inputimeout
Downloading inputimeout-1.0.4-py3-none-any.whl (4.6 kB)
Requirement already satisfied: Click>=7.0 in /usr/lib/python3/dist-packages (from edgesoftware) (7.0)
Collecting prettytable
Downloading prettytable-2.2.1-py3-none-any.whl (23 kB)
Collecting tqdm
Downloading tqdm-4.62.3-py2.py3-none-any.whl (76 kB)
|████████████████████████████████| 76 kB 745 kB/s
Collecting psutil
Downloading psutil-5.8.0-cp38-cp38-manylinux2010_x86_64.whl (296 kB)
|████████████████████████████████| 296 kB 13.6 MB/s
Collecting inquirer
Downloading inquirer-2.7.0-py2.py3-none-any.whl (31 kB)
Collecting pathlib
Downloading pathlib-1.0.1.tar.gz (49 kB)
|████████████████████████████████| 49 kB 5.0 MB/s
Collecting setuptools>=58.0.0
Downloading setuptools-58.3.0-py3-none-any.whl (946 kB)
|████████████████████████████████| 946 kB 16.0 MB/s
Collecting ruamel.yaml.clib>=0.1.2; platform_python_implementation == "CPython" and python_version < "3.10"
Downloading ruamel.yaml.clib-0.2.6-cp38-cp38-manylinux1_x86_64.whl (570 kB)
|████████████████████████████████| 570 kB 14.6 MB/s
Collecting websocket-client>=0.32.0
Downloading websocket_client-1.2.1-py2.py3-none-any.whl (52 kB)
|████████████████████████████████| 52 kB 218 kB/s
Collecting google-auth>=1.0.1
Downloading google_auth-2.3.2-py2.py3-none-any.whl (155 kB)
|████████████████████████████████| 155 kB 18.4 MB/s
Requirement already satisfied: urllib3>=1.24.2 in /usr/lib/python3/dist-packages (from kubernetes->edgesoftware) (1.25.8)
Requirement already satisfied: python-dateutil>=2.5.3 in /usr/lib/python3/dist-packages (from kubernetes->edgesoftware) (2.7.3)
Requirement already satisfied: certifi>=14.05.14 in /usr/lib/python3/dist-packages (from kubernetes->edgesoftware) (2019.11.28)
Collecting requests-oauthlib
Downloading requests_oauthlib-1.3.0-py2.py3-none-any.whl (23 kB)
Collecting wcwidth
Downloading wcwidth-0.2.5-py2.py3-none-any.whl (30 kB)
Collecting python-editor==1.0.4
Downloading python_editor-1.0.4-py3-none-any.whl (4.9 kB)
Collecting blessed==1.17.6
Downloading blessed-1.17.6-py2.py3-none-any.whl (76 kB)
|████████████████████████████████| 76 kB 809 kB/s
Collecting readchar==2.0.1
Downloading readchar-2.0.1-py3-none-any.whl (6.9 kB)
Collecting cachetools<5.0,>=2.0.0
Downloading cachetools-4.2.4-py3-none-any.whl (10 kB)
Collecting rsa<5,>=3.1.4; python_version >= "3.6"
Downloading rsa-4.7.2-py3-none-any.whl (34 kB)
Collecting pyasn1-modules>=0.2.1
Downloading pyasn1_modules-0.2.8-py2.py3-none-any.whl (155 kB)
|████████████████████████████████| 155 kB 16.0 MB/s
Requirement already satisfied: oauthlib>=3.0.0 in /usr/lib/python3/dist-packages (from requests-oauthlib->kubernetes->edgesoftware) (3.1.0)
Collecting pyasn1>=0.1.3
Downloading pyasn1-0.4.8-py2.py3-none-any.whl (77 kB)
|████████████████████████████████| 77 kB 613 kB/s
Building wheels for collected packages: wget, py-cpuinfo, termcolor, pathlib
Building wheel for wget (setup.py) ... done
Created wheel for wget: filename=wget-3.2-py3-none-any.whl size=9681 sha256=20d08506553d28fa546190cf0ff9fe0335b483c1c2fae4bfbb8977854c421725
Stored in directory: /home/vibhu/.cache/pip/wheels/bd/a8/c3/3cf2c14a1837a4e04bd98631724e81f33f462d86a1d895fae0
Building wheel for py-cpuinfo (setup.py) ... done
Created wheel for py-cpuinfo: filename=py_cpuinfo-8.0.0-py3-none-any.whl size=22245 sha256=c3dea2ccc39707d488c5151b3ca2b0341b17feafee4d1f53181832e1b1699f8a
Stored in directory: /home/vibhu/.cache/pip/wheels/57/cb/6d/bab2257f26c5be4a96ff65c3d2a7122c96529b73773ee37f36
Building wheel for termcolor (setup.py) ... done
Created wheel for termcolor: filename=termcolor-1.1.0-py3-none-any.whl size=4830 sha256=3fbcfa68fb966e0b4ca62fc10b87bd9633baee3603d41d067ee69a18a6e71d82
Stored in directory: /home/vibhu/.cache/pip/wheels/a0/16/9c/5473df82468f958445479c59e784896fa24f4a5fc024b0f501
Building wheel for pathlib (setup.py) ... done
Created wheel for pathlib: filename=pathlib-1.0.1-py3-none-any.whl size=14346 sha256=6eb8bbe7363bc713dc2d1659536697c62c3a870ec8549b57f6f26803b1577e02
Stored in directory: /home/vibhu/.cache/pip/wheels/59/02/2f/ff4a3e16a518feb111ae1405908094483ef56fec0dfa39e571
Successfully built wget py-cpuinfo termcolor pathlib
ERROR: launchpadlib 1.10.13 requires testresources, which is not installed.
Installing collected packages: ruamel.yaml.clib, ruamel.yaml, scp, wget, PyYAML, defusedxml, websocket-client, docker, setuptools, cachetools, pyasn1, rsa, pyasn1-modules, google-auth, requests-oauthlib, kubernetes, oyaml, py-cpuinfo, termcolor, inputimeout, wcwidth, prettytable, tqdm, psutil, python-editor, blessed, readchar, inquirer, pathlib, edgesoftware
WARNING: The scripts pyrsa-decrypt, pyrsa-encrypt, pyrsa-keygen, pyrsa-priv2pub, pyrsa-sign and pyrsa-verify are installed in '/home/vibhu/.local/bin' which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
WARNING: The script cpuinfo is installed in '/home/vibhu/.local/bin' which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
WARNING: The script tqdm is installed in '/home/vibhu/.local/bin' which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
WARNING: The script edgesoftware is installed in '/home/vibhu/.local/bin' which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
Successfully installed PyYAML-6.0 blessed-1.17.6 cachetools-4.2.4 defusedxml-0.7.1 docker-5.0.3 edgesoftware-1.0.0 google-auth-2.3.2 inputimeout-1.0.4 inquirer-2.7.0 kubernetes-19.15.0 oyaml-1.0 pathlib-1.0.1 prettytable-2.2.1 psutil-5.8.0 py-cpuinfo-8.0.0 pyasn1-0.4.8 pyasn1-modules-0.2.8 python-editor-1.0.4 readchar-2.0.1 requests-oauthlib-1.3.0 rsa-4.7.2 ruamel.yaml-0.17.16 ruamel.yaml.clib-0.2.6 scp-0.14.1 setuptools-58.3.0 termcolor-1.1.0 tqdm-4.62.3 wcwidth-0.2.5 websocket-client-1.2.1 wget-3.2

 

Labels (1)
0 Kudos
3 Replies
Sahira_Intel
Moderator
573 Views

Hi,

 

What software package are you trying to install? Also, what version are you installing?

 

Sincerely,

Sahira 

vibhu
Employee
566 Views

AWS cloud to edge pipeline module with latest version

Sahira_Intel
Moderator
487 Views

Hi Vibhu,

I apologize for my late response. I have ran the installation on my end and am not receiving the same error as long as I am running the installation in the correct directory. Can you delete the use case and then re download it, extract it and run the installation. 

 

Please let me know if you continue running into the same error.

Sincerely,

Sahira 

Reply