Intel® FPGA Software Installation & Licensing
Installation and Licensing that’s includes Intel Quartus® Prime software, ModelSim* - Intel FPGA Edition software, Nios® II Embedded Design Suite on Windows or Linux operating systems.
Announcements
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.

Can't Open Encrypted VHDL File

MReha2
Beginner
381 Views
I get the following error on Quartus Primte Lite when synthesizing the Intel DE10 Standard Computer FPGA:
     Error (10003): Can't open encrypted VHDL or Verilog HDL file   "C:/Users/Mark.Reha/Desktop/Testing/DE10-Standard_Computer-  new/verilog/Computer_System/synthesis/submodules/altera_nios2_gen2_rtl_module.sv" -- current license file does not contain a valid license for encrypted file
 
I have installed both Quartus Prime Lite 20.1 and 22.1 on my system.
I can synthesize the FPGA project on 22.1 but get the above error on 201.
I am trying to go back to only using Quartus Prime Lite 20.1 because it has ModelSim already installed.
I have tried to uninstall both versions of Quartus Prime Lite from my system and do a fresh install of 20.1 but cannot find a fix for this issue.
How can this issue be resolved?
 
The following is my general information:
Admin Name: Mark Reha
Email Address: mark.reha@gcu.edu
Company Name: Grand Canyon University
Company Address: 3300 W Camelback Rd, Phoenix, AZ 85017
Quartus version use: 20.1
NICID(Mac Add): 00-1C-42-29-E3-9E
0 Kudos
1 Solution
ShengN_Intel
Employee
280 Views

Hi,

 

With the following steps:

Go to Tools -> Platform Designer -> Load Computer_System.qsys -> Generate HDL (right-bottom) -> Recompile

I'm able to compile with the Quartus Lite v20.1 check image below:

ShengN_Intel_0-1674094411473.png

 

File attached below for your reference. May extract and compile.

 

Thanks,

Best regards,

Sheng

p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.

 

View solution in original post

8 Replies
ShengN_Intel
Employee
365 Views

Hi,

 

I guess you're downloading version 21.1 Monitor Program. It's recommended to use Quartus Lite version 21.1 and above. If not, probably there'll be some ip version mismatch issue like what you mentioned. If want to use version 20.1, have to regenerate HDL of the Computer_System.qsys and add in the newly generated .qip file.

Btw, I'm able to compile the project with Quartus Lite v21.1 check image below:

ShengN_Intel_0-1673591630863.png

 

 

Thanks,

Best regards,

Sheng

p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.

 

MReha2
Beginner
347 Views

I am already able to compile with 21.1.

I am not able to compile with 20.1 (I get the error as noted).

I would like to use 20.1 because ModelSim without any licensing hassles are included with 20.1.

I am a professor so licensing things can be a challenge with a large class size.

Either.....

How can I fix the error noted in 20.1? 

Or....

How can I get ModelSim (or equivalent) working in 21.1 without all the licensing hassles?

ShengN_Intel
Employee
333 Views

Hi,


If want to use version 20.1, have to open Computer_System.qsys and re-generate HDL. After that, recompile then the problem can be bypassed.

For version 21.1, the simulator supported is Questa which requires license.


Thanks,

Best regards,

Sheng

p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.


MReha2
Beginner
319 Views

Thanks so much for the info.

How do you re-generate the HDL in Quartus Prime Lite?

ShengN_Intel
Employee
305 Views

Hi,


Go to Tools -> Platform Designer -> Load Computer_System.qsys -> Generate HDL (right-bottom) -> Recompile


Thanks,

Best regards,

Sheng

p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.


MReha2
Beginner
287 Views

This produced hundreds of errors. Any other suggestions for how to get rid of my license file error?

Another option for me is, where can I get the DE10 Standard Computer project that complies with Quartus Lite 20.1? The DE10 Standard Computer project that I have compiles with 21.1 and then I have an older project that compiles with 18.x. 

 

Thanks in advance.

ShengN_Intel
Employee
281 Views

Hi,

 

With the following steps:

Go to Tools -> Platform Designer -> Load Computer_System.qsys -> Generate HDL (right-bottom) -> Recompile

I'm able to compile with the Quartus Lite v20.1 check image below:

ShengN_Intel_0-1674094411473.png

 

File attached below for your reference. May extract and compile.

 

Thanks,

Best regards,

Sheng

p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.

 

MReha2
Beginner
268 Views

THANKS! That worked great and I was able to compile on 20.1 and since 20.1 has ModelSim included my students can now easily run all their simulations. I really appreciate your help!

Reply