Intel® FPGA Software Installation & Licensing
Installation and Licensing that’s includes Intel Quartus® Prime software, ModelSim* - Intel FPGA Edition software, Nios® II Embedded Design Suite on Windows or Linux operating systems.

FPGA OpenCL installation

Quantitative_Finance
New Contributor I
338 Views

I am running Quartus Pro 21.3 with DE10-Pro Stratix 10 BSP from 20.3.  According to the installation guide, you need to set QUARTUS_ROOTDIR_OVERRIDE to quartus 20.3 path in order for you to use OpenCL 21.3 with an older BSP.  But, when I did that, both the flashing and the compilation still used 21.3 and the compilation failed indicating that it was using an older TCP/IP core with quartus.  Does 20.3 need to be in the path?  What does QUARTUS_ROOTDIR_OVERRIDE do?  Seems to me that it's useless and you just need to set Quartus 20.3 in the path while you have OpenCL pointing to 21.3.  What is the correct way to do this?

 

Thanks,

 

QG

0 Kudos
3 Replies
BoonBengT_Intel
Moderator
307 Views

Hi @Quantitative_Finance,

 

Thank you for posting in Intel community forum, hope all is well and apologies for the delayed in response.
Mind if I ask in which OS are you using? Assuming windows, are the environment variable set at the command prompt or manually in the system property?


Is the QUARTUS_ROOTDIR_OVERRIDE showing up when you echo the path or environment variables? Does the aocl install command run successfully?
Hope to hear from you soon.

 

Best Wishes
BB

BoonBengT_Intel
Moderator
281 Views

Hi @Quantitative_Finance,

Good day, just following up on the previous clarification.
By any chances did you managed to look into the it?

 

Best Wishes
BB

BoonBengT_Intel
Moderator
261 Views

Hi @Quantitative_Finance,

 

Greetings, as we do not receive any further clarification on what is provided, we would assume challenge are resolved. Hence thread will no longer be monitored. For new queries, please feel free to open a new thread and we will be right with you. Pleasure having you here.

Best Wishes
BB

Reply