Community
cancel
Showing results for 
Search instead for 
Did you mean: 
528 Views

How to debug jtagconfig not detecting JTAG hardware?

This is seen on quartus prime pro Linux version 16.0.0.211 installed on SLES 11 with udev rules as below:

ATTR{idVendor}=="09fb", ATTR{idProduct}=="6810", ACTION=="add", RUN+="/bin/sh -c 'chmod 666 /dev/$name'"

for USB blaster II cable:

Bus 001 Device 005: ID 09fb:6010 Altera

0 Kudos
5 Replies
YuanLi_S_Intel
Employee
246 Views

Hi Suhaini,

 

You will need to add rule depending on the linux version. You may refer to link below for the guide to setup USB Blaster II in Linux:

https://rocketboards.org/foswiki/Documentation/UsingUSBBlasterUnderLinux

 

Regards,

YL

246 Views

Hi YL,

 

IT support already added a rule below:

ATTR{idVendor}=="09fb", ATTR{idProduct}=="6810", ACTION=="add", RUN+="/bin/sh -c 'chmod 666 /dev/$name'"

 

is above rule good enough or do I have to follow the exact rule as in the link?

 

# USB-Blaster

SUBSYSTEM=="usb", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6001", MODE="0666"

SUBSYSTEM=="usb", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6002", MODE="0666"

 

SUBSYSTEM=="usb", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6003", MODE="0666"

 

# USB-Blaster II

SUBSYSTEM=="usb", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6010", MODE="0666"

SUBSYSTEM=="usb", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6810", MODE="0666"

 

YuanLi_S_Intel
Employee
246 Views

Hi Suhaini,

 

Yes. Just would like to confirm, have you followed the steps available at link below?

https://www.intel.com/content/www/us/en/programmable/documentation/iga1446847781805.html#iga14471826...

 

Regards,

YL

246 Views

Hi YL,

 

I have checked the steps in the link. In case programmer for statix 10 GX, I am using the USB Blaster II cable and I believe the programmer circuit is integrated into the development board. I connects only USB cable from host server to the card's micro USB receptacle. For power requirement, I believe it is handles by the board's power supply.

 

I also tried setting down TCK clock to 6Mhz using jtagconfig. However the command return no JTAG chain found.

 

In term of quartus installation, it is being installed in NFS disk and I invoke the program from the installation path after setting the appropriate LM_LICENSE_FILE variable.

 

 

Thanks,

Annuar

YuanLi_S_Intel
Employee
246 Views

Hi Annuar,

 

If you have followed the steps to setup in Linux, by right it shouldn't have any problem.

 

Please help me to understand the scenario so that i can help you:

  1. May i know, is your system detected the USB Blaster when it is connected to your system?
  2. If it is detected but you cannot find the JTAG using "jtagconfig -n" command, can you launch quartus programmer and setup as shown at link below?https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/ug/ug-intel-fpga-download-c... (Page 7)
  3. May i know are you using custom board or intel PSG development kit?

 

Regards,

YL

Reply