Intel® FPGA Software Installation & Licensing
Installation and Licensing that’s includes Intel Quartus® Prime software, ModelSim* - Intel FPGA Edition software, Nios® II Embedded Design Suite on Windows or Linux operating systems.
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
822 Discussions

Intel Modelsim launch error on Centos 7

LFahem
New Contributor I
727 Views

Hello, 

I have installed Quartus Prime Pro 17.1.0 on my PC having Centos7 as an OS. However, when I try to launch modelsim using vsim command I get the following error message:

Failed to obtain lock: couldn't open "/root/.modelsim_lock": file already exists
Error in startup script:
Initialization problem, exiting.

Initialization problem, exiting.

Initialization problem, exiting.

while executing
"Transcript::action_log "PROPREAD \"$key\" \"$value\"""
(procedure "VsimProperties::Init" line 59)
invoked from within
"VsimProperties::Init $MTIKeypath"
(procedure "PropertiesInit" line 18)
invoked from within
"PropertiesInit"
invoked from within
"ncFyP12 -+"
(file "/mtitcl/vsim/vsim" line 1)
** Fatal: Read failure in vlm process (0,0)

I have the following configuration:

  • Quartus version: 17.1.0
  • OS : centos-release-7-9.2009.1.el7.centos.x86_64

Thank you.

Lotfi

0 Kudos
1 Solution
LFahem
New Contributor I
646 Views

Hello,

Thank you for your response. Actually, I installed Modelsim with Quartus Pro 20.3 and the above error disappeared. I think that the libraries were correctly installed this time.

Lotfi.

View solution in original post

4 Replies
Nurina
Employee
702 Views

Hi Lotfi,


You received that error because of missing libraries. Unfortunately we have no proper workaround as CentOS 7 is not supported on ModelSim Intel FPGA: https://www.intel.com/content/www/us/en/programmable/support/support-resources/download/os-support.h...


You could try installing the equivalent or substitute packages listed for Red Hat Enterprise Linux from Table 2 of this document: https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/manual/quartus_install.pdf#...


Otherwise you'd have to use a different EDA simulation tool that supports CentOS 7.


Sorry for the inconvenience.

Regards,

Nurina


Nurina
Employee
659 Views

Hi Lotfi,

Any updates?

Nurina


LFahem
New Contributor I
647 Views

Hello,

Thank you for your response. Actually, I installed Modelsim with Quartus Pro 20.3 and the above error disappeared. I think that the libraries were correctly installed this time.

Lotfi.

Nurina
Employee
634 Views

Hi,

Glad your problem has been resolved. I now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.

Regards,
Nurina

P/S: If you like my comment, feel free to give Kudos. If my comment solved your problem, feel free to accept my comment as solution!

Reply