Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
1050 Discussions

Altera Monitor Program cannot load program to De1-SoC

Altera_Forum
Honored Contributor I
2,522 Views

https://alteraforum.com/forum/attachment.php?attachmentid=14669&stc=1 https://alteraforum.com/forum/attachment.php?attachmentid=14669&stc=1 I have been having issues using Altera Monitor Program to load compiled C/Assembly program to the De1SoC board.  

It says "could not query jtag instance ids, please ensure the fpga has been configured using the correct .sof file."  

 

However, I am 100% sure it's not due to the .sof file, since I tried both my own .sof file AND the DE1_SoC_Computer.sof files provided by the University Program. It's not due to the C/Assembly program either since I am using the sample files.  

Also I don't think it's due to my board/cable since I have no problem uploading the .sof file from Quartus. 

(By the way, when I am using Altera Monitor to download/upload the .sof file, it says "The system has been downloaded onto the board, but some JTAG devices could not be queried") 

 

https://alteraforum.com/forum/attachment.php?attachmentid=14670&stc=1  

I have been trying to solve it for 2 days, after reinstalling Quartus and the University Program several times, nearly desperate. If someone encountered the same problem before, please help! Thanks!
0 Kudos
5 Replies
RBarr16
Beginner
861 Views

I'm having a similar problem, have you fixed it?

SSchu40
Beginner
861 Views

Starting jtagd in <path to installation directory>/quartus/bin64 solved the problem for me.

HNguy150
Beginner
861 Views

I also met same proble someone can help me pleaseeeeeeeee

SSchu40
Beginner
861 Views

When I use the "Intel FPGA Monitor Program" I have similar problems. Usually retrying it multiple times, sometimes maybe even 5 times, solves such a problem for me always. I suspect it has to do with the USB implementation, but this should be fixed by those who have created the software/USB interface.

HNguy150
Beginner
861 Views

i also try many times but still can't resolve this problem. :(

 

Reply