Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
1082 Discussions

Altera Stratix I FPGA won't run user program!

JMart188
Beginner
328 Views

We have a Nios Development Kit Stratix I FPGA (EP1S40). We are using Quartus to program the board. We have a valid license which works and we have attempted to create a simply push-button->LED program. When we program the board, it says it is "successful", unfortunately, we are unable to get the board to run the user program. It always returns to its "safe mode" and runs the built-in hello-world program. We were wondering if we have to connect a jumper or something to get it to run our program?

 

Thank you

 

Jeremy Martin

University of Toronto

Canada

0 Kudos
1 Solution
Ahmed_H_Intel1
Employee
141 Views

Hi,

You must check the jumper that is responsible for selecting the configuration memory. There are different memories that can configure the FPGA which can be selected via a hardwired switch/jumper on the board. If you program such memory but it isn't been selected as the boot memory, you will never see your design running on the FPGA.

Regards,

 

View solution in original post

1 Reply
Ahmed_H_Intel1
Employee
142 Views

Hi,

You must check the jumper that is responsible for selecting the configuration memory. There are different memories that can configure the FPGA which can be selected via a hardwired switch/jumper on the board. If you program such memory but it isn't been selected as the boot memory, you will never see your design running on the FPGA.

Regards,

 

Reply