Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
1184 Discussions

DE2-115 university program VHDL support

cgehartung_Koeln
Beginner
1,370 Views

Where can I find support for my teaching SoPC development for my students who know VHDL?

Background: In Europe (Germany), I teach SoPC for years using DE2-115 boards and the old Quartus 13.0 version. I got support from the university program, especially the DE2-115 basic computer and DE2-115 media computer in a VHDL version (with underlying verilog files, but that's ok). In Europe VHDL is very popular, and therefore I concentrate on VHDL solutions.

The Intel FPGA university program (version 21.1) does only show Verilog support. Moreover, it does not fit to the latest version of Quartus Prime Lite (22.1). So I ask you to support me by answering the following questions:
- What is the latest university program version for SoPC on a DE2-115 where I get VHDL support?

- Where could I find the software for it? From the university program pages, there is only a restricted possibility to access older versions of Quartus, the university program files etc.

Labels (1)
0 Kudos
1 Solution
ShengN_Intel
Employee
1,316 Views

Hi,

 

The latest version is 21.1, you may find the software here https://fpgacademy.org/tools.html. Older version can't be accessed anymore.

 

Yes, version 21.1 does only show Verilog support. In order to change it to VHDL, have to re-generate the Platform Designer system in VHDL and re-create the top-level module in VHDL. I had help you out check DE2_115_Computer.vhd and DE2-115_Computer.zip.

 

Thanks,

Best regards,

Sheng

 

p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.

 

View solution in original post

4 Replies
ShengN_Intel
Employee
1,317 Views

Hi,

 

The latest version is 21.1, you may find the software here https://fpgacademy.org/tools.html. Older version can't be accessed anymore.

 

Yes, version 21.1 does only show Verilog support. In order to change it to VHDL, have to re-generate the Platform Designer system in VHDL and re-create the top-level module in VHDL. I had help you out check DE2_115_Computer.vhd and DE2-115_Computer.zip.

 

Thanks,

Best regards,

Sheng

 

p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.

 

_AK6DN_
Valued Contributor II
1,310 Views

The DE2-115 TerAsic board is CycloneII based, so the latest/only available support  for it in Quartus is version 13.0sp1.

If you expect to move to Quartus 21 (or any version other than 13.0sp1) it will require moving to a new hardware platform.

 

WRONG! Ignore this response. See following post.

0 Kudos
FvM
Valued Contributor III
1,296 Views
Hi,
DE2-115 is Cyclone IV based.
0 Kudos
_AK6DN_
Valued Contributor II
1,291 Views

You are 100% correct, my bad! Thanks for the correction.

0 Kudos
Reply